summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/unicode_plot/unicode_plot-0.0.5-r1.ebuild')
-rw-r--r--dev-ruby/unicode_plot/unicode_plot-0.0.5-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/unicode_plot/unicode_plot-0.0.5-r1.ebuild b/dev-ruby/unicode_plot/unicode_plot-0.0.5-r1.ebuild
new file mode 100644
index 00000000..ca9ad507
--- /dev/null
+++ b/dev-ruby/unicode_plot/unicode_plot-0.0.5-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="unicode_plot.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Plot your data by Unicode characters"
+HOMEPAGE="https://github.com/red-data-tools/unicode_plot.rb"
+SRC_URI="https://github.com/red-data-tools/unicode_plot.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="unicode_plot.rb-${PV}"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend ">=dev-ruby/enumerable-statistics-2.0.1"
+
+ruby_add_bdepend "dev-ruby/yard"