summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/overcommit/overcommit-0.62.0.ebuild')
-rw-r--r--dev-vcs/overcommit/overcommit-0.62.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/overcommit/overcommit-0.62.0.ebuild b/dev-vcs/overcommit/overcommit-0.62.0.ebuild
new file mode 100644
index 00000000..3026f22e
--- /dev/null
+++ b/dev-vcs/overcommit/overcommit-0.62.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="config libexec template-dir"
+
+RUBY_FAKEGEM_GEMSPEC="overcommit.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Opinionated Git Hook Manager"
+HOMEPAGE="https://github.com/sds/overcommit"
+SRC_URI="https://github.com/sds/overcommit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+
+ruby_add_rdepend "
+ || ( dev-ruby/childprocess:5 dev-ruby/childprocess:2 )
+ >=dev-ruby/iniparse-1.4:1
+ >=dev-ruby/rexml-3.2:3
+"
+
+all_ruby_prepare() {
+ sed -i -e "s/_relative //" ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ local hdir
+ hdir="$(ruby_fakegem_gemsdir)/gems/${RUBY_FAKEGEM_NAME}-${RUBY_FAKEGEM_VERSION}/template-dir/hooks"
+
+ fperms 0755 "${hdir}"/{commit-msg,overcommit-hook,post-checkout,post-commit,post-merge,post-rewrite,pre-commit,prepare-commit-msg,pre-push,pre-rebase}
+}