summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-08-21 19:28:19 +0300
committerAli Polatel <hawking@gentoo.org>2008-08-21 19:28:19 +0300
commiteae0add6cac6b38593be2b55bced185060785337 (patch)
tree1cd081e07263f10c45ba8cd962adac041ac17d68 /dev-lua/stdlib
parentAdded dev-lua/lrexlib (diff)
downloadhawking-eae0add6cac6b38593be2b55bced185060785337.tar.gz
hawking-eae0add6cac6b38593be2b55bced185060785337.tar.bz2
hawking-eae0add6cac6b38593be2b55bced185060785337.zip
Added dev-lua/stdlib
Diffstat (limited to 'dev-lua/stdlib')
-rw-r--r--dev-lua/stdlib/ChangeLog9
-rw-r--r--dev-lua/stdlib/Manifest3
-rw-r--r--dev-lua/stdlib/stdlib-6.ebuild38
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-lua/stdlib/ChangeLog b/dev-lua/stdlib/ChangeLog
new file mode 100644
index 0000000..69ce67b
--- /dev/null
+++ b/dev-lua/stdlib/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lua/stdlib
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*stdlib-6 (21 Aug 2008)
+
+ 21 Aug 2008; Ali Polatel <hawking@gentoo.org> +stdlib-6.ebuild:
+ Initial ebuild
+
diff --git a/dev-lua/stdlib/Manifest b/dev-lua/stdlib/Manifest
new file mode 100644
index 0000000..595ef3b
--- /dev/null
+++ b/dev-lua/stdlib/Manifest
@@ -0,0 +1,3 @@
+DIST stdlib-6.tar.gz 31021 RMD160 cc398bde081581ece8a618d82a7fee72abc62eeb SHA1 5da20c626fc2e78a49991a952229a150de9fbaaa SHA256 f3e228e94be2950fd4ce48e6ae5d9bbd55abd5f5bac2f451177a8d41af89585c
+EBUILD stdlib-6.ebuild 734 RMD160 29b5241c869eefa9844e987bccbd5ddc24909ada SHA1 282ec96eb4bd35f1cf29c373eef3611596d20945 SHA256 cb98395947046680480b80b1a63a64b88e4059922dab19d6aec24d70f9b10bc7
+MISC ChangeLog 224 RMD160 87ddeba5003b4d9c3c3cbf9cf6be3b5746c75e66 SHA1 a2ce2677b2774e2d6caa0fdfc1a3af1b8530759d SHA256 8571bb90a1b751ab1f8874b16621f44f3885e0f87d1fa742e64ca737a8e535b4
diff --git a/dev-lua/stdlib/stdlib-6.ebuild b/dev-lua/stdlib/stdlib-6.ebuild
new file mode 100644
index 0000000..6895c77
--- /dev/null
+++ b/dev-lua/stdlib/stdlib-6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit multilib
+
+DESCRIPTION="Lua library of modules for common programming tasks"
+HOMEPAGE="http://luaforge.net/projects/stdlib/"
+SRC_URI="http://luaforge.net/frs/download.php/3584/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="dev-lang/lua"
+RDEPEND="${DEPEND}
+ >=dev-lua/lrexlib-2.2.0"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local luaver=
+ luaver="$(lua -v 2>&1| cut -d' ' -f2)"
+ luaver="${luaver%.*}"
+
+ insinto /usr/$(get_libdir)/lua/${luaver}
+ doins modules/*.lua || die "doins failed"
+
+ if use doc; then
+ dohtml -r modules/* || die "dohtml failed"
+ fi
+}
+