summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-04-22 12:36:25 +0300
committerAli Polatel <hawking@gentoo.org>2008-04-22 12:36:25 +0300
commitaaa592e0e4d10d0f755fd7665adbdfc13575bfe5 (patch)
treec23e7cca694e65a67ebd4412fe7dcf51e8f24da4 /games-board
parentadded manifest1_obselete (diff)
downloadhawking-aaa592e0e4d10d0f755fd7665adbdfc13575bfe5.tar.gz
hawking-aaa592e0e4d10d0f755fd7665adbdfc13575bfe5.tar.bz2
hawking-aaa592e0e4d10d0f755fd7665adbdfc13575bfe5.zip
ngboard, initial version.
Diffstat (limited to 'games-board')
-rw-r--r--games-board/ngboard/Manifest2
-rw-r--r--games-board/ngboard/files/void-ptr-64bit.patch14
-rw-r--r--games-board/ngboard/ngboard-9999.ebuild53
3 files changed, 69 insertions, 0 deletions
diff --git a/games-board/ngboard/Manifest b/games-board/ngboard/Manifest
new file mode 100644
index 0000000..5c57def
--- /dev/null
+++ b/games-board/ngboard/Manifest
@@ -0,0 +1,2 @@
+AUX void-ptr-64bit.patch 583 RMD160 f8314ad3f5d8cde2d746f3ee0e3418a0066ad5a8 SHA1 fbdb49b779728ed7dc0442ca300f06800784c95c SHA256 aad5a52258a1ded597d500debf657bd120105d2f45ed17f0317c7c7fb1d8db6c
+EBUILD ngboard-9999.ebuild 1065 RMD160 6bba2d4675b76c95c6202efda5c801bbbc2064d9 SHA1 de005369ebadb66bb98db231c8c40ce9078c8f97 SHA256 cd5248526aae7ed16da5e1e877f8f0f4e87dbf8c7910fd8c0358022e038bcc09
diff --git a/games-board/ngboard/files/void-ptr-64bit.patch b/games-board/ngboard/files/void-ptr-64bit.patch
new file mode 100644
index 0000000..2bf5011
--- /dev/null
+++ b/games-board/ngboard/files/void-ptr-64bit.patch
@@ -0,0 +1,14 @@
+void* is 64 bit on amd64
+diff --git a/src/consoleframe.cc b/src/consoleframe.cc
+index 07ad6cd..86b2ef7 100644
+--- a/src/consoleframe.cc
++++ b/src/consoleframe.cc
+@@ -669,7 +669,7 @@ void ConsoleFrame::on_textview_event_after(GdkEvent *event)
+ TagVector tags = cursor_it.get_tags();
+ for (TagVector::iterator it = tags.begin();
+ it != tags.end(); ++it) {
+- int i = reinterpret_cast<int>((*it)->get_data("linkto"));
++ long int i = reinterpret_cast<long int>((*it)->get_data("linkto"));
+ if (i == 0) continue;
+
+ //get word start, end
diff --git a/games-board/ngboard/ngboard-9999.ebuild b/games-board/ngboard/ngboard-9999.ebuild
new file mode 100644
index 0000000..7c6e6e0
--- /dev/null
+++ b/games-board/ngboard/ngboard-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games subversion
+
+DESCRIPTION="Next generation chess interface"
+HOMEPAGE="http://ngboard.sourceforge.net/"
+
+ESVN_REPO_URI="http://ngboard.svn.sourceforge.net/svnroot/ngboard/trunk"
+ESVN_BOOTSTRAP="./autogen.sh"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-cpp/cairomm
+ dev-cpp/gtkmm
+ dev-libs/libpcre
+ dev-cpp/libxmlpp
+ gnome-base/gnome-common
+ gnome-base/librsvg
+ media-libs/gstreamer"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/libpcre cxx; then
+ eerror "dev-libs/libpcre needs to be built with cxx USE flag"
+ die "dev-libs/libpcre built without cxx"
+ fi
+}
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+
+ epatch "${FILESDIR}"/void-ptr-64bit.patch
+}
+
+src_compile() {
+ egamesconf
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto /usr/share/games/${PN}/sounds
+ doins -r sounds || die "doins failed"
+
+ prepgamesdirs
+}