summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-03-15 19:12:58 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-03-15 19:12:58 +0000
commit579e2fca6125e1ce282d210475ae5819e5c9ceb0 (patch)
treeb0350ef5309d8401135dd2323d3582da8c6eb0d1
parentInitial commit for boost-* 1.46.1 stuff (diff)
downloadhwoarang-579e2fca6125e1ce282d210475ae5819e5c9ceb0.tar.gz
hwoarang-579e2fca6125e1ce282d210475ae5819e5c9ceb0.tar.bz2
hwoarang-579e2fca6125e1ce282d210475ae5819e5c9ceb0.zip
More boost fixes thanks to few_
-rw-r--r--dev-libs/boost/boost-1.46.1.ebuild11
-rw-r--r--dev-libs/boost/files/point_release_naming_fix.patch14
-rw-r--r--dev-libs/boost/files/random-Jamfile-1.46.115
-rw-r--r--dev-libs/boost/files/remove-toolset-1.46.1.patch11
4 files changed, 48 insertions, 3 deletions
diff --git a/dev-libs/boost/boost-1.46.1.ebuild b/dev-libs/boost/boost-1.46.1.ebuild
index 7555494..93a922e 100644
--- a/dev-libs/boost/boost-1.46.1.ebuild
+++ b/dev-libs/boost/boost-1.46.1.ebuild
@@ -84,13 +84,17 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/remove-toolset-1.45.0.patch"
+ epatch "${FILESDIR}/remove-toolset-${PV}.patch"
# This enables building the boost.random library with /dev/urandom support
if [[ -e /dev/urandom ]] ; then
- mkdir -p libs/random/build
- cp "${FILESDIR}/random-Jamfile-1.45.0" libs/random/build/Jamfile.v2
+ mkdir -p libs/random/build || die
+ cp "${FILESDIR}/random-Jamfile-${PV}" libs/random/build/Jamfile.v2 || die
fi
+
+ # Ensure that the include dir and the libraries always have X_Y in their name if the boost version is X.Y.Z.
+ # By default the build system changes this to X_Y_Z if Z > 0, which breaks eselect-boost and some ebuilds.
+ epatch "${FILESDIR}/point_release_naming_fix.patch"
}
src_configure() {
@@ -268,6 +272,7 @@ src_install () {
-r tools || die
insinto /usr/share/doc/${PF}/html
doins -r libs || die
+ doins -r more || die
# To avoid broken links
insinto /usr/share/doc/${PF}/html
diff --git a/dev-libs/boost/files/point_release_naming_fix.patch b/dev-libs/boost/files/point_release_naming_fix.patch
new file mode 100644
index 0000000..8da5efa
--- /dev/null
+++ b/dev-libs/boost/files/point_release_naming_fix.patch
@@ -0,0 +1,14 @@
+--- Jamroot.orig 2011-03-15 12:49:05.000000000 +0000
++++ Jamroot 2011-03-15 12:49:20.000000000 +0000
+@@ -150,10 +150,7 @@
+
+ local version-tag = [ MATCH "^([^.]+)[.]([^.]+)[.]([^.]+)" : $(BOOST_VERSION) ]
+ ;
+-if $(version-tag[3]) = 0
+-{
+- version-tag = $(version-tag[1-2]) ;
+-}
++version-tag = $(version-tag[1-2]) ;
+
+ constant BOOST_VERSION_TAG : $(version-tag:J="_") ;
+
diff --git a/dev-libs/boost/files/random-Jamfile-1.46.1 b/dev-libs/boost/files/random-Jamfile-1.46.1
new file mode 100644
index 0000000..81fb136
--- /dev/null
+++ b/dev-libs/boost/files/random-Jamfile-1.46.1
@@ -0,0 +1,15 @@
+# Copyright (c) 2006 Tiziano Mueller
+#
+# Use, modification and distribution of the file is subject to the
+# Boost Software License, Version 1.0.
+# (See at http://www.boost.org/LICENSE_1_0.txt)
+
+
+project boost/random
+ : source-location ../src ;
+
+SOURCES = random_device ;
+
+lib boost_random
+ : $(SOURCES).cpp
+ : <link>shared:<define>BOOST_RANDOM_DYN_LINK=1 ;
diff --git a/dev-libs/boost/files/remove-toolset-1.46.1.patch b/dev-libs/boost/files/remove-toolset-1.46.1.patch
new file mode 100644
index 0000000..c80191c
--- /dev/null
+++ b/dev-libs/boost/files/remove-toolset-1.46.1.patch
@@ -0,0 +1,11 @@
+--- Jamroot 2010-11-17 11:51:56.000000000 +0200
++++ Jamroot.gentoo 2011-01-06 15:07:17.893270002 +0200
+@@ -377,7 +377,7 @@
+ if $(layout) = versioned
+ {
+ result = [ common.format-name
+- <base> <toolset> <threading> <runtime> -$(BOOST_VERSION_TAG)
++ <base> <threading> <runtime> -$(BOOST_VERSION_TAG)
+ -$(BUILD_ID)
+ : $(name) : $(type) : $(property-set) ] ;
+ }