summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-03-11 12:48:12 +0200
committerMarkos Chandras <hwoarang@gentoo.org>2012-03-11 12:48:12 +0200
commitf71369569fca39af536a2695120f21de61655d70 (patch)
treeedd94d2502d5baa7afe8ef25e61e8feeaf1a5585
parentmetadata/layout: Add missing masters entry (diff)
downloadhwoarang-f71369569fca39af536a2695120f21de61655d70.tar.gz
hwoarang-f71369569fca39af536a2695120f21de61655d70.tar.bz2
hwoarang-f71369569fca39af536a2695120f21de61655d70.zip
app-emulation/phpvirtualbox: Restore ebuild
-rw-r--r--app-emulation/phpvirtualbox/Manifest2
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-4.1.7.ebuild51
2 files changed, 52 insertions, 1 deletions
diff --git a/app-emulation/phpvirtualbox/Manifest b/app-emulation/phpvirtualbox/Manifest
index d864f89..2b752c9 100644
--- a/app-emulation/phpvirtualbox/Manifest
+++ b/app-emulation/phpvirtualbox/Manifest
@@ -1 +1 @@
-DIST phpvirtualbox-4.1-3.zip 2852666 RMD160 6d928aa357903dac2e039e78ff944f4ee3f0f31c SHA1 e52b4fa208fc64bc9520c11b504f57b619ceeadb SHA256 af4984a4b44ec3574f8d6ae737387814c80ac520e489239064d06bb5cd1b2c1d
+DIST phpvirtualbox-4.1-7.zip 2760199 RMD160 bbc14f536f4b8c060ff70196a060ca45b0d1feca SHA1 7788d4820148840899c61b32dc30f0c9f65c3e0c SHA256 16c27cd1bcc843b464752c3dd7091247b690218bca06fcecbdd130c5daf70b7c
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7.ebuild
new file mode 100644
index 0000000..f2ba8f7
--- /dev/null
+++ b/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $$
+
+EAPI="2"
+
+inherit versionator eutils webapp depend.php
+
+MY_PV="$(replace_version_separator 2 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Web-based administration for VirtualBox in PHP"
+HOMEPAGE="http://phpvirtualbox.googlecode.com"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/php[session,unicode,soap,gd]
+"
+DEPEND="app-arch/unzip"
+
+need_php_httpd
+
+src_install() {
+ webapp_src_preinst
+
+ cd ${MY_P}
+
+ dodoc CHANGELOG.txt LICENSE.txt README.txt || die
+ rm -f CHANGELOG.txt LICENSE.txt README.txt
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ elog "Local or remote virtualbox hosts must be compiled with"
+ elog "'vboxwebsrv' useflag and the respective init script"
+ elog "must be running to use this interface"
+ elog " /etc/init.d/vboxwebsrv start"
+}
+