aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-06-05 11:40:16 +0200
committerJohannes Huber <johu@gentoo.org>2017-06-05 11:40:16 +0200
commit6f29367052bf095283c43a2cdd3e73a502f7e7ea (patch)
treee3253ac15b75c389dbdd70f24db936204a823ef8
parentnet-irc/quassel: Add github repo uri (diff)
downloadjohu-6f29367052bf095283c43a2cdd3e73a502f7e7ea.tar.gz
johu-6f29367052bf095283c43a2cdd3e73a502f7e7ea.tar.bz2
johu-6f29367052bf095283c43a2cdd3e73a502f7e7ea.zip
app-editors/atom-bin: Version bump 1.16.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2 RepoMan-Options: --force
-rw-r--r--app-editors/atom-bin/Manifest1
-rw-r--r--app-editors/atom-bin/atom-bin-1.16.0.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/app-editors/atom-bin/Manifest b/app-editors/atom-bin/Manifest
index 9d1c74e..c15aec0 100644
--- a/app-editors/atom-bin/Manifest
+++ b/app-editors/atom-bin/Manifest
@@ -1 +1,2 @@
DIST atom-amd64-1.15.0.tar.gz 86441675 SHA256 308a0d74ba82531dd28e39b87c7a122e50a9cee5c7d59dd7a2a3bc48d5862ee0 SHA512 96566db7a4b2b951b7f091bbf69e302957029a0b90c6a0182d49adc9445bd41401933906558173c65dd01f9e46261ef29fdb33069c666a6c5eef8fe849f400f5 WHIRLPOOL a36fedf1fab441cd24c8fb07a9b56c5f62be765ac0b7a1fa52f890a0d185e7fd0a577880dee1d60e3a8a620d6b55bf4855c390e91757f39bfffb65f3f9c7bf66
+DIST atom-amd64-1.16.0.tar.gz 90189086 SHA256 702291d01b487d7fb5a4ce703ba374abeffdf2990e6ca87d13b74ea8ba96c0e1 SHA512 59b66ec35b17fb3abecf7f743de61e42523b05f22652ae555faee55dd8f70d985994085837ce370425f9d4f730feeef486973ce9f8cc5fecbcb6d8ef1b0528de WHIRLPOOL 5f88e4bd585a3c2d0aea6fb2c64c20fc2887f3dffc225e494f5238d5d0ccd4980ec23a1e0ebfd9b0f78be92b9f0afafeda88c34fc0000cce99a4c2c5cdefe0aa
diff --git a/app-editors/atom-bin/atom-bin-1.16.0.ebuild b/app-editors/atom-bin/atom-bin-1.16.0.ebuild
new file mode 100644
index 0000000..79d214b
--- /dev/null
+++ b/app-editors/atom-bin/atom-bin-1.16.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit flag-o-matic python-any-r1 eutils unpacker pax-utils
+
+DESCRIPTION="A hackable text editor for the 21st Century. - Binary package"
+HOMEPAGE="https://atom.io"
+MY_PN="atom"
+SRC_URI="
+ amd64? ( https://github.com/${MY_PN}/${MY_PN}/releases/download/v${PV}/${MY_PN}-amd64.tar.gz -> ${MY_PN}-amd64-${PV}.tar.gz )
+"
+
+RESTRICT="mirror"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="MIT"
+
+IUSE="system-node"
+
+DEPEND="${PYTHON_DEPS}
+ media-fonts/inconsolata
+ !!dev-util/atom-shell
+ !dev-util/apm
+ !app-editors/atom"
+
+RDEPEND="${DEPEND}
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ gnome-base/libgnome-keyring
+ dev-libs/nss
+ dev-libs/nspr
+ gnome-base/gconf
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/libcap
+ system-node? ( net-libs/nodejs[npm] )
+ x11-libs/libXtst
+ x11-libs/pango"
+
+QA_PRESTRIPPED="
+ /usr/share/${MY_PN}/${MY_PN}
+ /usr/share/${MY_PN}/chromedriver/chromedriver
+ /usr/share/${MY_PN}/libffmpegsumo.so
+ /usr/share/${MY_PN}/libnotify.so.4
+ /usr/share/${MY_PN}/libchromiumcontent.so
+ /usr/share/${MY_PN}/libgcrypt.so.11
+ /usr/share/${MY_PN}/resources/app.asar.unpacked/node_modules/symbols-view/vendor/ctags-linux"
+
+S="${WORKDIR}/${MY_PN}-${PV}-amd64"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare(){
+ #If you want to use the system node, we don't need the local one, so we must delete it first
+ if use system-node; then
+ rm resources/app/apm/bin/node
+ rm resources/app/apm/bin/npm
+ #Fix apm binary to use the nodejs binary rather than the built-in
+ sed -i "s#\$binDir\/\$nodeBin#\$\(which \$nodeBin\)#" resources/app/apm/bin/apm
+ fi
+ eapply_user
+}
+
+src_install() {
+ pax-mark m ${MY_PN}
+ insinto ${EPREFIX}/usr/share/${MY_PN}
+ doins -r .
+ doicon ${MY_PN}.png
+ insinto ${EPREFIX}/usr/share/doc/${MY_PN}
+ newins resources/LICENSE.md copyright
+ newbin ${FILESDIR}/${PN} ${MY_PN}
+ insinto ${EPREFIX}/usr/share/lintian/overrides
+ newins ${FILESDIR}/${MY_PN}-lintian ${MY_PN}
+ dosym ${EPREFIX}/usr/share/${MY_PN}/resources/app/apm/bin/apm ${EPREFIX}/usr/bin/apm
+
+ # Fixes permissions
+ fperms +x /usr/bin/${MY_PN}
+ fperms +x /usr/share/${MY_PN}/${MY_PN}
+ fperms +x /usr/share/${MY_PN}/resources/app/${MY_PN}.sh
+ if use !system-node; then
+ fperms +x /usr/share/${MY_PN}/resources/app/apm/bin/node
+ fperms +x /usr/share/${MY_PN}/resources/app/apm/bin/npm
+ fi
+ fperms +x /usr/share/${MY_PN}/resources/app/apm/bin/apm
+ fperms +x /usr/share/${MY_PN}/resources/app/apm/node_modules/npm/bin/node-gyp-bin/node-gyp
+ fperms +x /usr/share/${MY_PN}/resources/app.asar.unpacked/node_modules/symbols-view/vendor/ctags-linux
+
+ make_desktop_entry "/usr/bin/${MY_PN} %U" "${MY_PN}" "${MY_PN}" \
+ "GNOME;GTK;Utility;TextEditor;Development;" \
+ "GenericName=Text Editor\nMimeType=text/plain;\nStartupNotify=true\nStartupWMClass=${MY_PN}"
+}