summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2015-03-03 17:12:42 +0200
committerMart Raudsepp <leio@gentoo.org>2015-03-03 17:12:42 +0200
commit1ed843a75423e90a70903343c9c710d6b0b214e7 (patch)
tree358b59a1bf0c8f4c64a9afae46cbfae2ea7cf02c
parentkodi: append glesv2 and egl cflags and ldflags, to help kodi find them from /... (diff)
downloadleio-1ed843a75423e90a70903343c9c710d6b0b214e7.tar.gz
leio-1ed843a75423e90a70903343c9c710d6b0b214e7.tar.bz2
leio-1ed843a75423e90a70903343c9c710d6b0b214e7.zip
gtk+:3 - bump and sync with main tree
-rw-r--r--x11-libs/gtk+/Manifest2
-rw-r--r--x11-libs/gtk+/gtk+-3.14.9.ebuild (renamed from x11-libs/gtk+/gtk+-3.14.8.ebuild)20
2 files changed, 4 insertions, 18 deletions
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index 311da31..88b83d1 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,2 +1,2 @@
DIST gtk+-2.24.26.tar.xz 13328708 SHA256 d84fc0f1e3cd99e8b9ec756e754f42653940638579a8f28d0eabffc37018d133 SHA512 2a3a366c41214fcacbc2a69719d5b20060e0efbb0576a1fc4f4123f97ea1f5ff1b06296302806655b32c06901629f5d23b91d65de9a01143053f63607d94498d WHIRLPOOL b0cf44be24dd1999f2f4aeb6ed779e536cb00c7d1b42cb1a4c8fc9a807093a1b8f26f4f750bb52533ca6a18e6a9ce481f7d879e0c186d7d11add6c793090c244
-DIST gtk+-3.14.8.tar.xz 15689624 SHA256 7a543ea8a85f2c8a7b7374f24fd57df454067858689d8b02ec6c90f24be2b344 SHA512 110f39d0a8ef72bfcb02d8e11000210848da15d7232346277f9755c7918e16af39dce78ba409ddfcb73dd5fa9032cc51843cb658d5ce4a2b32ca401624cc5240 WHIRLPOOL 115a043e332119bc3fe582744ceeeb9a49f4361ded13131162c26fc6988f1c2c5281738e992c96580b96ea2bd966377a49f239ec6204d6072a5dbb09d4b0f22f
+DIST gtk+-3.14.9.tar.xz 15716588 SHA256 3be9560e6e99388d7706a168e3353ecd63fc30ec4f7f8bea23889e71ab7b6c64 SHA512 3b64142d65ec4b4e0ed709c2fac629d80b95dac03481a3d6f8e3cc6c351ac779fe172a1edee552df7b3c40287f10c97fa0e99212e5f0e6b4751e3d8efd0896e5 WHIRLPOOL bc45b3722913ebb90bff944ec724909d01e3e976d49f8bd273500de2af9de7dcedc85e24fca36226816993a10cb87f4477f4498cc67946449855b37a0790a2fa
diff --git a/x11-libs/gtk+/gtk+-3.14.8.ebuild b/x11-libs/gtk+/gtk+-3.14.9.ebuild
index e1bb493..582d933 100644
--- a/x11-libs/gtk+/gtk+-3.14.8.ebuild
+++ b/x11-libs/gtk+/gtk+-3.14.9.ebuild
@@ -13,12 +13,7 @@ HOMEPAGE="http://www.gtk.org/"
LICENSE="LGPL-2+"
SLOT="3"
-# NOTE: This gtk+ has multi-gdk-backend support, see:
-# * http://blogs.gnome.org/kris/2010/12/29/gdk-3-0-on-mac-os-x/
-# * http://mail.gnome.org/archives/gtk-devel-list/2010-November/msg00099.html
-# I tried this and got it all compiling, but the end result is unusable as it
-# horribly mixes up the backends -- grobian
-IUSE="aqua cloudprint colord cups examples gtk3-only +introspection test vim-syntax wayland X xinerama"
+IUSE="aqua broadway cloudprint colord cups examples gtk3-only +introspection test vim-syntax wayland X xinerama"
REQUIRED_USE="
|| ( aqua wayland X )
xinerama? ( X )
@@ -146,6 +141,7 @@ multilib_src_configure() {
ECONF_SOURCE=${S} \
gnome2_src_configure \
$(use_enable aqua quartz-backend) \
+ $(use_enable broadway broadway-backend) \
$(use_enable cloudprint) \
$(use_enable colord) \
$(use_enable cups cups auto) \
@@ -175,16 +171,6 @@ multilib_src_configure() {
}
multilib_src_test() {
- # Tests require a new gnome-themes-standard, but adding it to DEPEND
- # would result in circular dependencies.
- # https://bugzilla.gnome.org/show_bug.cgi?id=669562
- if ! has_version '>=x11-themes/gnome-themes-standard-3.6[gtk]'; then
- ewarn "Tests will be skipped because >=gnome-themes-standard-3.6[gtk]"
- ewarn "is not installed. Please re-run tests after installing the"
- ewarn "required version of gnome-themes-standard."
- return 0
- fi
-
# FIXME: this should be handled at eclass level
"${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
@@ -196,7 +182,7 @@ multilib_src_test() {
multilib_src_install() {
gnome2_src_install
- # add -framework Carbon to the .pc files
+ # add -framework Carbon to the .pc files, bug #????
if use aqua ; then
for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
sed -e "s:Libs\: :Libs\: -framework Carbon :" \