summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2015-02-19 17:11:13 +0200
committerMart Raudsepp <leio@gentoo.org>2015-02-19 17:11:13 +0200
commite73797ec977e3406a04fd4d0fb14899c32b7d433 (patch)
tree7303e18004fb5eeeac239c9d0499cc7918c2c8e8 /x11-wm/maynard/maynard-9999.ebuild
parentPreliminary xf86-video-fbturbo for RPi usages (diff)
downloadleio-e73797ec977e3406a04fd4d0fb14899c32b7d433.tar.gz
leio-e73797ec977e3406a04fd4d0fb14899c32b7d433.tar.bz2
leio-e73797ec977e3406a04fd4d0fb14899c32b7d433.zip
Add a preliminary ebuild for maynard desktop env
Diffstat (limited to 'x11-wm/maynard/maynard-9999.ebuild')
-rw-r--r--x11-wm/maynard/maynard-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-wm/maynard/maynard-9999.ebuild b/x11-wm/maynard/maynard-9999.ebuild
new file mode 100644
index 0000000..28ac8ab
--- /dev/null
+++ b/x11-wm/maynard/maynard-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils autotools git-2
+EGIT_REPO_URI="https://github.com/raspberrypi/maynard.git"
+SRC_URI=""
+KEYWORDS=""
+
+DESCRIPTION="Desktop environment designed for the Raspberry Pi"
+HOMEPAGE="https://github.com/raspberrypi/maynard/wiki"
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-libs/wayland-1.0.2
+ >=dev-libs/weston-1.5.91
+ >=x11-libs/gtk+-3.10:3[wayland]
+ gnome-base/gnome-menus:3
+ gnome-base/gnome-desktop:3
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40"
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}
+
+pkg_postinst() {
+ ewarn "Maynard requires a background from kde-wallpapers, which does not seem"
+ ewarn "to be even provided anymore. Set the BACKGROUND environment variable"
+ ewarn "to point to a background image that exists, in order to be able to"
+ ewarn "launch Maynard for now."
+ # FIXME: Additionally opening the application menu freezes weston for me
+}