summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2018-03-12 20:18:22 +0100
committerThomas Raschbacher <lordvan@gentoo.org>2018-03-12 20:18:22 +0100
commit9b75760989559a5fb9983e40aa14747485c61120 (patch)
treef43b27c492e8281b65c09de5d913998d160ba9e6 /dev-libs/efl/efl-1.20.7.ebuild
parentnew ebuild for efl without eclass and patch for libunwind (diff)
downloadlordvan-9b75760989559a5fb9983e40aa14747485c61120.tar.gz
lordvan-9b75760989559a5fb9983e40aa14747485c61120.tar.bz2
lordvan-9b75760989559a5fb9983e40aa14747485c61120.zip
misc fixes + doc & examples
Diffstat (limited to 'dev-libs/efl/efl-1.20.7.ebuild')
-rw-r--r--dev-libs/efl/efl-1.20.7.ebuild186
1 files changed, 105 insertions, 81 deletions
diff --git a/dev-libs/efl/efl-1.20.7.ebuild b/dev-libs/efl/efl-1.20.7.ebuild
index 1ee8e15..b35d072 100644
--- a/dev-libs/efl/efl-1.20.7.ebuild
+++ b/dev-libs/efl/efl-1.20.7.ebuild
@@ -8,13 +8,13 @@ SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
HOMEPAGE="https://www.enlightenment.org/about-efl"
-inherit pax-utils
+inherit pax-utils autotools gnome2-utils xdg-utils
#eutils autotools
DESCRIPTION="Enlightenment Foundation Libraries all-in-one package"
LICENSE="BSD-2 GPL-2 LGPL-2.1 ZLIB"
-IUSE="+bmp debug doc drm +eet egl fbcon +fontconfig fribidi gif gles glib gnutls gstreamer harfbuzz +ico ibus jpeg2k libressl neon nls oldlua opengl ssl physics pixman +png postscript +ppm +psd pulseaudio raw scim sdl sound systemd tga tiff tslib unwind v4l valgrind wayland webp X xim xine xpm"
+IUSE="+bmp debug doc drm +eet egl examples fbcon +fontconfig fribidi gif gles glib gnutls gstreamer harfbuzz +ico ibus jpeg2k libressl lz4 neon nls oldlua opengl ssl physics pixman +png postscript +ppm +psd pulseaudio raw scim sdl sound systemd tga tiff tslib unwind v4l valgrind wayland webp X xim xine xpm"
SLOT="0"
@@ -51,13 +51,14 @@ RDEPEND="
libressl? ( dev-libs/libressl )
)
)
- gstreamer? (
+ || (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
)
harfbuzz? ( media-libs/harfbuzz )
ibus? ( app-i18n/ibus )
jpeg2k? ( media-libs/openjpeg:0 )
+ lz4? ( app-arch/lz4 )
!oldlua? ( >=dev-lang/luajit-2.0.0 )
oldlua? ( dev-lang/lua:* )
physics? ( >=sci-physics/bullet-2.80 )
@@ -166,10 +167,13 @@ DEPEND="
S=${WORKDIR}/${MY_P}
-#src_prepare() {
+src_prepare() {
+ default
# epatch "${FILESDIR}/efl-1.20.7_autotools_libunwind.patch"
-# eautoreconf
-#}
+# eapply "${FILESDIR}/efl-1.20.7_autotools_libunwind.patch"
+# eapply_user
+ eautoreconf
+}
src_configure() {
if use ssl && use gnutls ; then
@@ -181,80 +185,87 @@ src_configure() {
einfo "opengl has been selected for you."
fi
- econf \
- --with-profile=$(usex debug debug release)\
- --with-crypto=$(usex gnutls gnutls $(usex ssl openssl none)) \
- --with-x11=$(usex X xlib none) \
- $(use_with X x) \
- --with-opengl=$(usex opengl full $(usex gles es none)) \
- --with-glib=$(usex glib) \
- $(use_enable bmp image-loader-bmp) \
- $(use_enable bmp image-loader-wbmp) \
- $(use_enable drm) \
- $(use_enable doc) \
- $(use_enable eet image-loader-eet) \
- $(use_enable egl) \
- $(use_enable fbcon fb) \
- $(use_enable fontconfig) \
- $(use_enable fribidi) \
- $(use_enable gif image-loader-gif) \
- --enable-gstreamer1 \
- --disable-gstreamer \
- $(use_enable harfbuzz) \
- $(use_enable ico image-loader-ico) \
- $(use_enable ibus) \
- $(use_enable jpeg2k image-loader-jp2k) \
- $(use_enable neon) \
- $(use_enable nls) \
- $(use_enable oldlua lua-old) \
- $(use_enable physics) \
- $(use_enable pixman) \
- $(use_enable pixman pixman-font) \
- $(use_enable pixman pixman-rect) \
- $(use_enable pixman pixman-line) \
- $(use_enable pixman pixman-poly) \
- $(use_enable pixman pixman-image) \
- $(use_enable pixman pixman-image-scale-sample) \
- $(use_enable png image-loader-png) \
- $(use_enable postscript spectre) \
- $(use_enable ppm image-loader-pmaps) \
- $(use_enable psd image-loader-psd) \
- $(use_enable pulseaudio) \
- $(use_enable raw libraw) \
- $(use_enable scim) \
- $(use_enable sdl) \
- $(use_enable sound audio) \
- $(use_enable systemd) \
- $(use_enable tga image-loader-tga) \
- $(use_enable tiff image-loader-tiff) \
- $(use_enable tslib) \
- $(use_enable v4l v4l2) \
- $(use_enable valgrind) \
- $(use_enable wayland) \
- $(use_enable webp image-loader-webp) \
- $(use_enable xim) \
- $(use_enable xine) \
- $(use_enable xpm image-loader-xpm) \
- $(use_enable unwind libunwind) \
- --enable-cserve \
- --enable-image-loader-generic \
- --enable-image-loader-jpeg \
- --disable-tizen \
- --disable-gesture \
- --disable-gstreamer \
- --enable-xinput2 \
- --disable-xinput22 \
+ local config=(
+ --with-profile=$(usex debug debug release)
+ --with-crypto=$(usex gnutls gnutls $(usex ssl openssl none))
+ --with-x11=$(usex X xlib none)
+ $(use_with X x)
+ --with-opengl=$(usex opengl full $(usex gles es none))
+ --with-glib=$(usex glib)
+ $(use_enable bmp image-loader-bmp)
+ $(use_enable bmp image-loader-wbmp)
+ $(use_enable drm)
+ $(use_enable doc)
+ $(use_enable eet image-loader-eet)
+ $(use_enable egl)
+ $(use_enable fbcon fb)
+ $(use_enable fontconfig)
+ $(use_enable fribidi)
+ $(use_enable gif image-loader-gif)
+ --enable-gstreamer1
+ --disable-gstreamer
+ $(use_enable harfbuzz)
+ $(use_enable ico image-loader-ico)
+ $(use_enable ibus)
+ $(use_enable jpeg2k image-loader-jp2k)
+ $(use_enable lz4 liblz4)
+ $(use_enable neon)
+ $(use_enable nls)
+ $(use_enable oldlua lua-old)
+ $(use_enable physics)
+ $(use_enable pixman)
+ $(use_enable pixman pixman-font)
+ $(use_enable pixman pixman-rect)
+ $(use_enable pixman pixman-line)
+ $(use_enable pixman pixman-poly)
+ $(use_enable pixman pixman-image)
+ $(use_enable pixman pixman-image-scale-sample)
+ $(use_enable png image-loader-png)
+ $(use_enable postscript spectre)
+ $(use_enable ppm image-loader-pmaps)
+ $(use_enable psd image-loader-psd)
+ $(use_enable pulseaudio)
+ $(use_enable raw libraw)
+ $(use_enable scim)
+ $(use_enable sdl)
+ $(use_enable sound audio)
+ $(use_enable systemd)
+ $(use_enable tga image-loader-tga)
+ $(use_enable tiff image-loader-tiff)
+ $(use_enable tslib)
+ $(use_enable v4l v4l2)
+ $(use_enable valgrind)
+ $(use_enable wayland)
+ $(use_enable webp image-loader-webp)
+ $(use_enable xim)
+ $(use_enable xine)
+ $(use_enable xpm image-loader-xpm)
+ $(use_enable unwind libunwind)
+ --enable-cserve
+ --enable-image-loader-generic
+ --enable-image-loader-jpeg
+ --disable-tizen
+ --disable-gesture
+ --disable-gstreamer
+ --enable-xinput2
+ --disable-xinput22
--enable-libmount
+ )
- # require gstreamer since upstream strongly discourages not using it
- # $(use_enable gstreamer gstreamer1) \
+ # require gstreamer since upstream strongly discourages not using it
+ # and not going to enable that:
+ # enable_i_really_know_what_i_am_doing_and_that_this_will_probably_break_things_and_i_will_fix_them_myself_and_send_patches_abb
+ # $(use_enable gstreamer gstreamer1) \
+ # testing lz4
+ # external lz4 support currently broken because of unstable ABI/API
+ #--enable-liblz4
+ ECONF_SOURCE="$S" econf "${config[@]}"
- # external lz4 support currently broken because of unstable ABI/API
- #--enable-liblz4
}
-#src_compile() {
+src_compile() {
+ default
# if host-is-pax && ! use oldlua ; then
# # We need to build the lua code first so we can pax-mark it. #547076
# local target='_e_built_sources_target_gogogo_'
@@ -263,11 +274,24 @@ src_configure() {
# emake -C src bin/elua/elua
# pax-mark m src/bin/elua/.libs/elua
# fi
-# enlightenment_src_compile
-#}
+ use examples && emake examples
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ DOCS=( ABOUT-NLS AUTHORS ChangeLog COMPLIANCE COPYING INSTALL NEWS README )
+ use doc && HTML_DOCS=( doc/html )
+ einstalldocs
+ use examples && emake DESTDIR="${D}" install-examples
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_mimeinfo_database_update
+}
-#src_install() {
-# MAKEOPTS+=" -j1"
-#
-# enlightenment_src_install
-#}
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_mimeinfo_database_update
+}