summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/flux-git/flux-git-0.1.ebuild')
-rw-r--r--media-video/flux-git/flux-git-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-video/flux-git/flux-git-0.1.ebuild b/media-video/flux-git/flux-git-0.1.ebuild
new file mode 100644
index 0000000..3b46eb0
--- /dev/null
+++ b/media-video/flux-git/flux-git-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git autotools
+
+EGIT_REPO_URI="git://live.polito.it/var/git/flux.git"
+EGIT_BOOTSTRAP="eautoreconf"
+
+AT_M4DIR="m4"
+
+DESCRIPTION="RTP streams multiplexer"
+HOMEPAGE="http://live.polito.it/documentation/flux"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+IUSE="ffmpeg"
+
+RDEPEND="ffmpeg? ( media-video/ffmpeg )
+ media-video/netembryo-git
+ dev-libs/bufferpool-git"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf --localstatedir=/var `use_with ffmpeg libavcodec` || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc README
+}