summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2009-02-18 16:34:49 +0000
committerMatti Bickel <mabi@gentoo.org>2009-02-18 16:34:49 +0000
commit9a30d2959fc25f752e4b1949fdb03982fa1ed2ff (patch)
tree565315533524d9c24b1f3e013f06a5b3f915e7d3 /sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild
parentfix bug #209635 (diff)
downloadmabi-9a30d2959fc25f752e4b1949fdb03982fa1ed2ff.tar.gz
mabi-9a30d2959fc25f752e4b1949fdb03982fa1ed2ff.tar.bz2
mabi-9a30d2959fc25f752e4b1949fdb03982fa1ed2ff.zip
add mpi-dotnetHEADmaster
svn path=/; revision=17
Diffstat (limited to 'sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild')
-rw-r--r--sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild b/sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild
new file mode 100644
index 0000000..89587bc
--- /dev/null
+++ b/sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+WANT_AUTOTOOLS="2.5"
+inherit autotools mono
+
+# "." is not allowed as part of a package name
+MY_PN="mpi.net"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="C# bindings for various MPI-implementations"
+HOMEPAGE="http://www.osl.iu.edu/research/mpi.net"
+SRC_URI="http://www.osl.iu.edu/research/mpi.net/files/${PV}/${MY_P}.tar.gz"
+
+LICENSE="Boost"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+DEPEND="virtual/mpi
+ >=dev-lang/mono-2.0"
+RDEPEND="${DEPEND}"
+
+MPICC="${CC}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/configure.ac.patch"
+ epatch "${FILESDIR}/Makefile.am.patch"
+ epatch "${FILESDIR}/Unsafe.pl.patch"
+
+ # MPI/Makefile seems broken, fix it
+ eautoreconf
+}
+
+src_compile() {
+ # policy requires us to build shared and static libs alongside
+ econf --enable-shared --enable-static
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}
+
+src_test() {
+ make check -k
+}