summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/indicator-application/files/indicator-application-0.0.19-bindings-automagic.patch')
-rw-r--r--gnome-extra/indicator-application/files/indicator-application-0.0.19-bindings-automagic.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/gnome-extra/indicator-application/files/indicator-application-0.0.19-bindings-automagic.patch b/gnome-extra/indicator-application/files/indicator-application-0.0.19-bindings-automagic.patch
new file mode 100644
index 0000000..f00cbd0
--- /dev/null
+++ b/gnome-extra/indicator-application/files/indicator-application-0.0.19-bindings-automagic.patch
@@ -0,0 +1,67 @@
+From: Romain Perier <mrpouet@gentoo.org>
+Date: Sun, 4 Apr 2010 17:39:50 +0200
+Subject: Do not build bindings as automagic supports, they should be optionnal
+
+---
+ bindings/Makefile.am | 12 +++++++++---
+ configure.ac | 8 ++++++++
+ 2 files changed, 17 insertions(+), 3 deletions(-)
+
+--- a/bindings/Makefile.am
++++ b/bindings/Makefile.am
+@@ -1,3 +1,9 @@
+-SUBDIRS = \
+- mono \
+- python
++SUBDIRS=
++
++if BUILD_MONO
++SUBDIRS += mono
++endif
++
++if BUILD_PYTHON
++SUBDIRS += python
++endif
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,7 +55,9 @@ AC_SUBST(INDICATOR_LIBS)
+ ###########################
+ # Check for Mono support
+ ###########################
++AC_ARG_ENABLE([mono], [AC_HELP_STRING([--enable-mono], [Build Mono binding])], enable_mono="$enableval", enable_mono="auto")
+
++if test "x$enable_mono" != "xno"; then
+ MONO_REQUIRED_VERSION=1.0
+ PKG_CHECK_MODULES(MONO_DEPENDENCY, mono >= $MONO_REQUIRED_VERSION, has_mono=true, has_mono=false)
+
+@@ -109,7 +111,9 @@ AC_SUBST(GAPI_FIXUP)
+
+ PKG_CHECK_MODULES(NUNIT, nunit >= 2.4.7)
+ AC_SUBST(NUNIT_LIBS)
++fi
+
++AM_CONDITIONAL([BUILD_MONO], [test "x$enable_mono" != "xno"])
+ ###########################
+ # Check to see if we're local
+ ###########################
+@@ -145,7 +149,9 @@ AC_SUBST(DBUSSERVICEDIR)
+ ###########################
+ # Python
+ ###########################
++AC_ARG_ENABLE([python], [AC_HELP_STRING([--enable-python], [Build Python binding])], enable_python="$enableval", enable_python="auto")
+
++if test "x$enable_python" != "xno"; then
+ PYGTK_REQUIRED=2.14.0
+ PYGOBJECT_REQUIRED=0.22
+
+@@ -170,7 +176,9 @@ AC_MSG_CHECKING(for pygtk codegen)
+ PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
+ AC_SUBST(PYGTK_CODEGEN)
+ AC_MSG_RESULT($PYGTK_CODEGEN)
++fi
+
++AM_CONDITIONAL([BUILD_PYTHON], [test "x$enable_python" != "xno"])
+ ###########################
+ # Files
+ ###########################
+