summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xlrd/xlrd-0.7.1-r256.ebuild')
-rw-r--r--dev-python/xlrd/xlrd-0.7.1-r256.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/xlrd/xlrd-0.7.1-r256.ebuild b/dev-python/xlrd/xlrd-0.7.1-r256.ebuild
new file mode 100644
index 0000000..b058ea9
--- /dev/null
+++ b/dev-python/xlrd/xlrd-0.7.1-r256.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+EAPI="4"
+
+#USE_PYTHON="python25 python26 python27"
+PYTHON_OPTIONAL="no"
+
+inherit python-distutils-ng
+
+DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
+HOMEPAGE="http://pypi.python.org/pypi/xlrd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+python_unpack_all() {
+ : echo " ### python_unpack_all ### (${@}) PYTHON=${PYTHON}"
+ unpack ${A} # Not needed
+}
+
+python_prepare_all() {
+ : echo " ### python_prepare_all ### (${@}) PYTHON=${PYTHON}"
+ sed -i \
+ -e "s,'doc,# 'doc,g" \
+ -e "s,'exa,# 'exa,g" \
+ setup.py || die
+}
+
+python_prepare() {
+ : echo " ### python_prepare ### (${@}) PYTHON=${PYTHON}"
+}
+
+python_configure() {
+ : echo " ### python_configure ### (${@}) PYTHON=${PYTHON}"
+}
+
+python_compile() {
+ : echo " ### python_compile ### (${@}) PYTHON=${PYTHON}"
+ ${PYTHON} setup.py build || die
+}
+
+python_test() {
+ : echo " ### python_test ### (${@}) PYTHON=${PYTHON}"
+}
+
+python_install() {
+ : echo " ### python_install ### (${@}) PYTHON=${PYTHON}"
+ ${PYTHON} setup.py install --no-compile --root="${D}/" || die
+}
+
+python_install_all() {
+ : echo " ### python_install_all ### (${@}) PYTHON=${PYTHON}"
+ rm -f "${D}/usr/bin"/*.py || die
+
+ python-distutils-ng_doscript scripts/runxlrd.py
+
+ dohtml xlrd/doc/*.html
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ doins -r xlrd/examples
+ fi
+}