summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_google_authenticator/pam_google_authenticator-9999.ebuild')
-rw-r--r--sys-auth/pam_google_authenticator/pam_google_authenticator-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-auth/pam_google_authenticator/pam_google_authenticator-9999.ebuild b/sys-auth/pam_google_authenticator/pam_google_authenticator-9999.ebuild
new file mode 100644
index 0000000..7c8be13
--- /dev/null
+++ b/sys-auth/pam_google_authenticator/pam_google_authenticator-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+inherit eutils base mercurial pam toolchain-funcs
+
+DESCRIPTION="Example PAM module demonstrating two-factor authentication"
+HOMEPAGE="http://code.google.com/p/google-authenticator/"
+SRC_URI=""
+EHG_REPO_URI="https://google-authenticator.googlecode.com/hg/libpam/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}
+ media-gfx/qrencode"
+PATCHES="${FILESDIR}/${P}-as-needed.patch ${FILESDIR}/exit_codes.patch"
+
+S="${WORKDIR}/libpam"
+
+src_unpack() {
+ mercurial_fetch "${EHG_REPO_URI}" "$(basename "${EHG_REPO_URI}")" "${WORKDIR}"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dopammod pam_google_authenticator.so || die
+
+ dobin google-authenticator || die
+
+ dodoc README FILEFORMAT || die
+}