summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/passlib/Manifest5
-rw-r--r--dev-python/passlib/metadata.xml7
-rw-r--r--dev-python/passlib/passlib-1.3.1.ebuild32
-rw-r--r--dev-python/passlib/passlib-1.6.1.ebuild32
-rw-r--r--dev-python/python-pam/Manifest3
-rw-r--r--dev-python/python-pam/metadata.xml7
-rw-r--r--dev-python/python-pam/python-pam-0.1.4.ebuild25
-rw-r--r--dev-python/python-swiftclient/Manifest2
-rw-r--r--dev-python/python-swiftclient/metadata.xml11
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-1.2.0.ebuild25
-rw-r--r--sys-cluster/swift/ChangeLog11
-rw-r--r--sys-cluster/swift/Manifest8
-rw-r--r--sys-cluster/swift/files/swift-account.initd36
-rw-r--r--sys-cluster/swift/files/swift-container.initd36
-rw-r--r--sys-cluster/swift/files/swift-object.initd36
-rw-r--r--sys-cluster/swift/files/swift-proxy.initd57
-rw-r--r--sys-cluster/swift/metadata.xml16
-rw-r--r--sys-cluster/swift/swift-1.7.4.ebuild117
18 files changed, 0 insertions, 466 deletions
diff --git a/dev-python/passlib/Manifest b/dev-python/passlib/Manifest
deleted file mode 100644
index 9dfcfce..0000000
--- a/dev-python/passlib/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST passlib-1.3.1.tar.gz 151494 SHA256 4cb312e18ee2c0f107a36799107dfd2e05c51faa54c5678397c38d89f35f1328
-DIST passlib-1.6.1.tar.gz 395855 SHA256 00cfb564feb2d97ebaf6b28acdc9277a0c73c3c1df7b2a7b65605c76e724177b SHA512 93c047dc0a06f19a20e5da97db43c5c76e06d69baeac15cc932ef0306ae22dac5c1a3925889a140fd181ab4e00ac513ec829951e15babf5aad89bd2d08dc9907 WHIRLPOOL b0840a1fd903000db06c1739d902e01c3cc4fb9f63692b0316fd60bd3393fa5be134037476da135306cc258fe38853269ebbb424d13f45edda9dd1c1b370d957
-EBUILD passlib-1.3.1.ebuild 696 SHA256 a617be6e2ae0480e71ca23ca7b0ffd278d86cea7553feba7f535fe660250710f SHA512 025db95d9e6bcdf7ee01b5eed6232e1cea58c71d9998931460a4e36a9443f8ef57571228782ed306968ae0438657698cc9a180e5cfcc20ab9899ea7de5c772c4 WHIRLPOOL d7e65c6757a41274934c50ca00154c29b3f7306a9596f3dc6a3dd23ef9b35e2716e73df52d8bdfbfe05e51a809d4beed5af9ed9d2ace5387026cea6b59b39e3e
-EBUILD passlib-1.6.1.ebuild 696 SHA256 a617be6e2ae0480e71ca23ca7b0ffd278d86cea7553feba7f535fe660250710f SHA512 025db95d9e6bcdf7ee01b5eed6232e1cea58c71d9998931460a4e36a9443f8ef57571228782ed306968ae0438657698cc9a180e5cfcc20ab9899ea7de5c772c4 WHIRLPOOL d7e65c6757a41274934c50ca00154c29b3f7306a9596f3dc6a3dd23ef9b35e2716e73df52d8bdfbfe05e51a809d4beed5af9ed9d2ace5387026cea6b59b39e3e
-MISC metadata.xml 187 SHA256 773142fc211f4f8cd167704604281cbf366eabef6751c52a2895f63e9761a5a2 SHA512 81ef1f7d248dbdf4183b6700885e86071cee75bc1b69c3ed590c18193743da2562be527f212f088fe8ae9242b0aaaf7907912badae1264f14c2f5dde619c3fba WHIRLPOOL 32c1d67c8a74e4f3606e5aedc066ea7cdf09292beea0574c25d7448294b42ee9146a7724fcb9a7da04558e55c07619702e38e90656b962638cf747cb2c67ede3
diff --git a/dev-python/passlib/metadata.xml b/dev-python/passlib/metadata.xml
deleted file mode 100644
index d034107..0000000
--- a/dev-python/passlib/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<longdescription lang="en">
-</longdescription>
-</pkgmetadata>
-
diff --git a/dev-python/passlib/passlib-1.3.1.ebuild b/dev-python/passlib/passlib-1.3.1.ebuild
deleted file mode 100644
index 13c968f..0000000
--- a/dev-python/passlib/passlib-1.3.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-# Ebuild generated by g-pypi 0.2.2 (rev. 214)
-
-EAPI=3
-#RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="comprehensive password hashing framework supporting over 20 schemes"
-HOMEPAGE="http://code.google.com/p/passlib/"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-LICENSE="BSD-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="test doc"
-DEPEND="dev-python/setuptools
- test? ( dev-python/nose )"
-RDEPEND=""
-
-src_install() {
- distutils_src_install
- if use doc; then
- dodoc "${S}"/docs/*
- fi
-
-}
-
-src_test() {
- PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
-}
diff --git a/dev-python/passlib/passlib-1.6.1.ebuild b/dev-python/passlib/passlib-1.6.1.ebuild
deleted file mode 100644
index 13c968f..0000000
--- a/dev-python/passlib/passlib-1.6.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-# Ebuild generated by g-pypi 0.2.2 (rev. 214)
-
-EAPI=3
-#RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="comprehensive password hashing framework supporting over 20 schemes"
-HOMEPAGE="http://code.google.com/p/passlib/"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-LICENSE="BSD-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="test doc"
-DEPEND="dev-python/setuptools
- test? ( dev-python/nose )"
-RDEPEND=""
-
-src_install() {
- distutils_src_install
- if use doc; then
- dodoc "${S}"/docs/*
- fi
-
-}
-
-src_test() {
- PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
-}
diff --git a/dev-python/python-pam/Manifest b/dev-python/python-pam/Manifest
deleted file mode 100644
index f6e6bac..0000000
--- a/dev-python/python-pam/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pam-0.1.4.tar.gz 2637 SHA256 35e88575afc37a2a5f96e20b22fa55d3e3213370d4ce640af1597c2a1dde226b SHA512 a8bce582f8ed375a5e503ec0b8e4853164125222e9cee40f6f6509def5fbeaf0eb0d2242b0ef7405024b7f8cfc0660ea7c43d266e8923a1a2ff3054135f5da63 WHIRLPOOL 6ee3ae35888d6f07963bc061f457243c8fcc2495e84febb316074d43873e89bf9563c8d00f5202ec6a4aabecc06cfc3e0e9cf5a49814298ba9c61cf5c4ef4491
-EBUILD python-pam-0.1.4.ebuild 584 SHA256 28ebc2fa78fadd827fe3386763efe1d416a79820e612ba3a237a151203fe331a SHA512 5ac935420dc30ef807ba4428c07e021920fdf25c58716f86e3bf45466ada324a26e03a11c1d5feaf5dd5e7037f2f8928d6fd485cbdca01a4d5fa54a32e7569e9 WHIRLPOOL a5dded4702850aa64b5f977bac656b875152eb84d8b093e44b73b9add28ce99bd543b578cee5c6c643d990620ed8183f9944403e9facbd2451ce02268b9592f0
-MISC metadata.xml 187 SHA256 773142fc211f4f8cd167704604281cbf366eabef6751c52a2895f63e9761a5a2 SHA512 81ef1f7d248dbdf4183b6700885e86071cee75bc1b69c3ed590c18193743da2562be527f212f088fe8ae9242b0aaaf7907912badae1264f14c2f5dde619c3fba WHIRLPOOL 32c1d67c8a74e4f3606e5aedc066ea7cdf09292beea0574c25d7448294b42ee9146a7724fcb9a7da04558e55c07619702e38e90656b962638cf747cb2c67ede3
diff --git a/dev-python/python-pam/metadata.xml b/dev-python/python-pam/metadata.xml
deleted file mode 100644
index d034107..0000000
--- a/dev-python/python-pam/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<longdescription lang="en">
-</longdescription>
-</pkgmetadata>
-
diff --git a/dev-python/python-pam/python-pam-0.1.4.ebuild b/dev-python/python-pam/python-pam-0.1.4.ebuild
deleted file mode 100644
index cf4fa43..0000000
--- a/dev-python/python-pam/python-pam-0.1.4.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-# Ebuild generated by g-pypi 0.2.2 (rev. 214)
-
-EAPI=4
-#RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_PN=${PN#python-}
-S="${WORKDIR}/${MY_PN}-${PV}"
-DESCRIPTION="A python interface to the PAM library on linux using ctypes."
-HOMEPAGE="http://atlee.ca/software/pam"
-SRC_URI="mirror://pypi/p/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-LICENSE="BSD-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE=""
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-src_install() {
- distutils_src_install
-}
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
deleted file mode 100644
index 88ed2ec..0000000
--- a/dev-python/python-swiftclient/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-EBUILD python-swiftclient-1.2.0.ebuild 568 SHA256 dddff62a926b60516da84f414b40a6c5a2965ce1cea0ab390e7c9b16a189f09e SHA512 94678ffa9c2d8d8af110296f5b584a246c51b76bdb291413f9654a1c950b9cab22489f86723194afcbd26224dfde290faf457023b345b36c0d53e2f879dbdcfc WHIRLPOOL 01fc07f3ffdfc2379f65ee8eb5f1069ed91cc9b423532f54846f21d098b6c17977818d99916a93e6b8a90947787bfe431df2665dc83798251333f34865bad1b5
-MISC metadata.xml 323 SHA256 97e4defd9a3b763a49684a186cf615710fe3c893208bfd4640fb7ef0a576193f SHA512 03b6cfc7835743347b9279c7aafb05cccf8378a728adf85390059c3ba73afec272164ef59ee8e11965cbf9d26312c97a43603a354d456055e1c3c12c4b07e20d WHIRLPOOL bed51f25b8f94df301ee0744735dd029ec4e19f30b6ce43136fe12504812bc85e596a5bc42ef54b87d28ed85147f4213aaf690e2498588072f9715eec96656ec
diff --git a/dev-python/python-swiftclient/metadata.xml b/dev-python/python-swiftclient/metadata.xml
deleted file mode 100644
index 818e168..0000000
--- a/dev-python/python-swiftclient/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer>
- <email>prometheanfire@gentoo.org</email>
- </maintainer>
- <longdescription lang="en">
- Python bindings to the OpenStack Object Storage API
- </longdescription>
-</pkgmetadata>
-
diff --git a/dev-python/python-swiftclient/python-swiftclient-1.2.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-1.2.0.ebuild
deleted file mode 100644
index 8f5b081..0000000
--- a/dev-python/python-swiftclient/python-swiftclient-1.2.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-PYTHON_DEPEND=2
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit git-2 distutils
-
-DESCRIPTION="Python bindings to the OpenStack Object Storage API"
-HOMEPAGE="http://docs.openstack.org/developer/python-swiftclient"
-EGIT_REPO_URI="https://github.com/openstack/${PN}.git"
-# 1.2.0
-EGIT_COMMIT="68d1550"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-python/setuptools
- dev-python/simplejson"
-RDEPEND="${DEPEND}"
diff --git a/sys-cluster/swift/ChangeLog b/sys-cluster/swift/ChangeLog
deleted file mode 100644
index 5f93ac8..0000000
--- a/sys-cluster/swift/ChangeLog
+++ /dev/null
@@ -1,11 +0,0 @@
-# ChangeLog for sys-cluster/swift
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: $
-
-*swift-1.7.4 (31 Dec 2012)
-
- 31 Dec 2012; Matthew Thode <prometheanfire@gentoo.org> +swift-1.7.4.ebuild,
- +files/swift-proxy-server.initd, +files/swift-storage-server.confd,
- +files/swift-storage-server.initd, +metadata.xml:
- initial add of openstack-swift
-
diff --git a/sys-cluster/swift/Manifest b/sys-cluster/swift/Manifest
deleted file mode 100644
index 62c98f0..0000000
--- a/sys-cluster/swift/Manifest
+++ /dev/null
@@ -1,8 +0,0 @@
-AUX swift-account.initd 882 SHA256 d95e032cc56ea009da763dff4b6bca9c0c7a90ec7c7246e11e33cab6f2171fbc SHA512 69f0ed11ea27cda895c301c6c9c6b9de415d2edc2b47de8d145faf21527d052904273830f52c7b70415ce4304579b1be6f4c9d7f40f0b2fdf8a0734e298bbf1e WHIRLPOOL 27977b06a1f63111f9f9193e3b5f5555a7bf4228a5647e7061a91e764a199c757d2b02b1939297c0aaf6eed51982bf1f85e5128457a0dddfb9965df6a353d834
-AUX swift-container.initd 892 SHA256 e6fe709688fe9fe97c5fd242747bbeef3f581711845b6219fdcab317146f124c SHA512 33a500373fbe6f8984eb287824963906f2af53f604b225f173f2e880c5efd87fa9be0bdf78f34a4123dba87a6e3b6afd8c04bbe9a68911178fe69987f5eee48b WHIRLPOOL 6e2562bf10fd9ed5ea409ddf76ce8f333c2d8b7245b16e39443878a82681136c66f9a39c8a0e85b84a30b38d04a5b268367c45ddaa85338129bfa23ad5973f83
-AUX swift-object.initd 877 SHA256 22d529497e876a43b09a37238c90c6c46517973872850377014077c23df54857 SHA512 a2bbb3f3bdab0130748b0041d67da1064508ffad9578cce14361106a52bed7ef9cbd87d42ce23c74e86c3d8ac569de82b7d3383b3facbf7c37ebf9d2573d2516 WHIRLPOOL 75d77f037a1809e54548432d989d3efc8759eafd6e38eaf744cdcc1da3174cc9fc3d3ebc6992ffd56f8cde9454669d010f7940f6a0601c648fcca5344204f635
-AUX swift-proxy.initd 1394 SHA256 abd2aa12882c58ddb00a70a72fe74ce42e5aef0c861063e33e34643b26addc7a SHA512 05dde5c9e5778345cd00fa32683e102deeb9f98b526b8c01da2ab6f0bb5a4915872a5c800d9fdc976a7c40ad77b154de46d2422ea2ee897fab9c032f9d030376 WHIRLPOOL 965799071d7ca4c5442f3be738473b01655d17ac46765eb4bc72db18962fa41303887f48e4cc96990606b244f213dd70ea79f7fa5240db9d3a94c9daa9f00dff
-DIST swift-1.7.4.tar.gz 461286 SHA256 5c927cfd6aeba38689c1b8e0d1b6fd697999ad56012f6a4aff011d6018d55cd2 SHA512 c7527593beaede09a70e92b85823eb4661992a568377aea6254c7470dddf9ab64238361c84298b1c046c05abb781507bd7634fdff05d30c1e35e465d7f86cf78 WHIRLPOOL f78325e57a02a34e3f4a052778604115df71f2225861b6b4e9516c25d9b83d7bec7251de34da98f34618b7b586eaac747948192822f2998f3ddeb23fc12f999a
-EBUILD swift-1.7.4.ebuild 3353 SHA256 4e4593a46450d100e1ff953526c5e34653d2559a6bffec381289c0da48d12ebb SHA512 580a661222342660a510f840f551df63ff8a6ba878b1cb9033c0fd1acd243ede56f5f66735a5d2d0cb3a06473eae2e997d9e533c861261a83a5e04746b03f226 WHIRLPOOL c04d8deba8a3d7ec9018bc2bd92d37e10ca4ba722de4d9e70bc2a4ada4bb27b3c43ebad2f246b5845217789f61db3c74c86d16b61796e86bc3e194e8d69c7cf0
-MISC ChangeLog 380 SHA256 b66d44e1c09f502aa77ecb43804d948b25876cda652c23a303fa9ba82b6575dd SHA512 c8ee612811758a02596ae00b0ad739fa3e828880a610bb60d49d8ba18f1810578f4d0cb738d43d2480ecb7a8e34bf2e642042f06d1cb9f2d1501868a2d68c52a WHIRLPOOL 30a86afe00b7365f693a22e4a1078c41f289d8d07975b157b2a1556e5bed075b08adb2d10bfb7bb38c266c0e24680bcbd978935afff686142a0c3c0c4c621625
-MISC metadata.xml 459 SHA256 0fae6e325e3edc018763b46e9bafcd53b1a9ed3667823bf233f33add3d275364 SHA512 576c4d6e458e993562b8d627620a096fcabd1aa30dd179694342fd039d567177cd9707d7fdd2dd421c441ed5832bd6e6ded71aa3f16718fd4ee2a6b348dee064 WHIRLPOOL 268d900bf730122a227bde91616d43360de0eb5192b9affab9db936b36b90789bedceb7af25d9a6638e7b41a8ee081a0b0ea444c9a238791c8cf945b116f6c3f
diff --git a/sys-cluster/swift/files/swift-account.initd b/sys-cluster/swift/files/swift-account.initd
deleted file mode 100644
index 88fe05c..0000000
--- a/sys-cluster/swift/files/swift-account.initd
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-COMMAND=/usr/bin/swift-init
-PIDFILE=/var/run/swift/swift-account.pid
-
-depend() {
- after net
-}
-
-checkconfig() {
- if [ ! -r /etc/swift/swift.conf ]; then
- eerror "Missing required config file: /etc/swift/swift.conf"
- return 1
- fi
- if [ ! -r /etc/swift/account-server.conf ]; then
- eerror "Missing required config file: /etc/swift/account-server.conf"
- return 1
- fi
- return 0
-}
-
-start() {
- checkconfig || return $?
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --quiet -i --pidfile ${PIDFILE} ${COMMAND} -- account start
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --quiet -i --pidfile ${PIDFILE} ${COMMAND} -- account stop
- eend $?
-}
diff --git a/sys-cluster/swift/files/swift-container.initd b/sys-cluster/swift/files/swift-container.initd
deleted file mode 100644
index 0cde618..0000000
--- a/sys-cluster/swift/files/swift-container.initd
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-COMMAND=/usr/bin/swift-init
-PIDFILE=/var/run/swift/swift-container.pid
-
-depend() {
- after net
-}
-
-checkconfig() {
- if [ ! -r /etc/swift/swift.conf ]; then
- eerror "Missing required config file: /etc/swift/swift.conf"
- return 1
- fi
- if [ ! -r /etc/swift/container-server.conf ]; then
- eerror "Missing required config file: /etc/swift/container-server.conf"
- return 1
- fi
- return 0
-}
-
-start() {
- checkconfig || return $?
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --quiet -i --pidfile ${PIDFILE} ${COMMAND} -- container start
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --quiet -i --pidfile ${PIDFILE} ${COMMAND} -- container stop
- eend $?
-}
diff --git a/sys-cluster/swift/files/swift-object.initd b/sys-cluster/swift/files/swift-object.initd
deleted file mode 100644
index 0c547fd..0000000
--- a/sys-cluster/swift/files/swift-object.initd
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-COMMAND=/usr/bin/swift-init
-PIDFILE=/var/run/swift/swift-object.pid
-
-depend() {
- after net
-}
-
-checkconfig() {
- if [ ! -r /etc/swift/swift.conf ]; then
- eerror "Missing required config file: /etc/swift/swift.conf"
- return 1
- fi
- if [ ! -r /etc/swift/object-server.conf ]; then
- eerror "Missing required config file: /etc/swift/object-server.conf"
- return 1
- fi
- return 0
-}
-
-start() {
- checkconfig || return $?
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --quiet -i --pidfile ${PIDFILE} ${COMMAND} -- object start
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --quiet -i --pidfile ${PIDFILE} ${COMMAND} -- object stop
- eend $?
-}
diff --git a/sys-cluster/swift/files/swift-proxy.initd b/sys-cluster/swift/files/swift-proxy.initd
deleted file mode 100644
index 54ba467..0000000
--- a/sys-cluster/swift/files/swift-proxy.initd
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-COMMAND=/usr/bin/swift-init
-PIDFILE=/var/run/swift/swift-proxy.pid
-
-depend() {
- after net
-}
-
-opts="reload"
-
-checkconfig() {
- if [ ! -r /etc/swift/swift.conf ]; then
- eerror "Missing required config file: /etc/swift/swift.conf"
- return 1
- fi
- if [ ! -r /etc/swift/proxy-server.conf ]; then
- eerror "Missing required config file: /etc/swift/proxy-server.conf"
- return 1
- fi
- return 0
-}
-
-start() {
- checkconfig || return $?
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --quiet -i --pidfile ${PIDFILE} ${COMMAND} -- proxy start
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --quiet -i --pidfile ${PIDFILE} ${COMMAND} -- proxy stop
- eend $?
-}
-
-reload() {
- checkconfig || return $?
- ebegin "Reloading ${SVCNAME}"
- start-stop-daemon --quiet -i ${COMMAND} -- proxy reload
- eend $? "Failed to reload ${SVCNAME}"
-}
-
-restart() {
- checkconfig || return $?
- ebegin "Restarting ${SVCNAME}"
- start-stop-daemon --quiet -i --pidfile ${PIDFILE} ${COMMAND} -- proxy restart
- eend $? "Failed to restart ${SVCNAME}"
-}
-
-status() {
- start-stop-daemon --quiet -i ${COMMAND} -- proxy status
- eend $? "Failed to get status for ${SVCNAME}"
-}
diff --git a/sys-cluster/swift/metadata.xml b/sys-cluster/swift/metadata.xml
deleted file mode 100644
index d14b3d4..0000000
--- a/sys-cluster/swift/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <use>
- <flag name="memcache">adds memcached support</flag>
- </use>
- <maintainer>
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <longdescription lang="en">
- Swift is a highly available, distributed, eventually consistent object/blob
- store.
- </longdescription>
-</pkgmetadata>
-
diff --git a/sys-cluster/swift/swift-1.7.4.ebuild b/sys-cluster/swift/swift-1.7.4.ebuild
deleted file mode 100644
index 1f02d4b..0000000
--- a/sys-cluster/swift/swift-1.7.4.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-
-inherit distutils-r1 eutils linux-info
-
-DESCRIPTION="Swift is a highly available, distributed, eventually consistent
-object/blob store"
-HOMEPAGE="https://launchpad.net/swift"
-SRC_URI="http://launchpad.net/${PN}/folsom/${PV}/+download/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="proxy account container object test +memcache"
-
-DEPEND="dev-python/setuptools
- test? ( dev-python/nose
- dev-python/coverage
- dev-python/nosexcover
- dev-python/pep8
- dev-python/mock
- >=dev-python/sphinx-1.1.2 )"
-
-RDEPEND="dev-python/eventlet
- dev-python/greenlet
- dev-python/netifaces
- dev-python/pastedeploy
- dev-python/simplejson
- dev-python/pyxattr
- dev-python/configobj
- dev-python/webob
- >=dev-python/webob-1.0.8
- <dev-python/webob-1.3
- >=dev-python/python-swiftclient-1.2.0
- memcache? ( net-misc/memcached )
- net-misc/rsync"
-
-REQUIRED_USE="|| ( proxy account container object )"
-
-CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
-~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
-~ZFS"
-
-src_test () {
- sh .unittests || die
-}
-
-pkg_setup() {
- enewuser swift
- enewgroup swift
-}
-
-python_install() {
- distutils-r1_python_install
- keepdir /etc/swift
- insinto /etc/swift
-
- newins "etc/swift.conf-sample" "swift.conf"
- newins "etc/swift-bench.conf-sample" "swift-bench.conf-sample"
- newins "etc/rsyncd.conf-sample" "rsyncd.conf"
- newins "etc/mime.types-sample" "mime.types-sample"
- newins "etc/memcache.conf-sample" "memcache.conf-sample"
- newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
- newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
-
- if use proxy; then
- newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
- newins "etc/proxy-server.conf-sample" "proxy-server.conf"
- if use memcache; then
- sed -i '/depend/a\
- need memcached' "${D}/etc/init.d/swift-proxy"
- fi
- fi
- if use account; then
- newinitd "${FILESDIR}/swift-account.initd" "swift-account"
- newins "etc/account-server.conf-sample" "account-server.conf"
- fi
- if use container; then
- newinitd "${FILESDIR}/swift-container.initd" "swift-container"
- newins "etc/container-server.conf-sample" "container-server.conf"
- fi
- if use object; then
- newinitd "${FILESDIR}/swift-object.initd" "swift-obect"
- newins "etc/object-server.conf-sample" "object-server.conf"
- newins "etc/object-expirer.conf-sample" "object-expirer.conf"
- fi
-
- fowners swift:swift "/etc/swift" || die "fowners failed"
-}
-
-pkg_postinst() {
- elog "Openstack swift will default to using insecure http unless a"
- elog "certificate is created in /etc/swift/cert.crt and the associated key"
- elog "in /etc/swift/cert.key. These can be created with the following:"
- elog " * cd /etc/swift"
- elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
-}
-
-#src_install()
-#{
-# distutils_src_install
-#
-# dodir "/var/run/swift"
-#
-# if use proxy-server; then
-# newinitd "${FILESDIR}/swift-proxy-server.initd" swift-proxy-server
-# fi
-#
-# if use storage-server; then
-# newinitd "${FILESDIR}/swift-storage-server.initd" swift-storage-server
-# newconfd "${FILESDIR}/swift-storage-server.confd" swift-storage-server
-# fi
-#}