summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/keystone/keystone-2012.2.ebuild')
-rw-r--r--sys-auth/keystone/keystone-2012.2.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/sys-auth/keystone/keystone-2012.2.ebuild b/sys-auth/keystone/keystone-2012.2.ebuild
deleted file mode 100644
index cee9779..0000000
--- a/sys-auth/keystone/keystone-2012.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Keystone is the Openstack authentication, authorization, and
-service catalog written in Python."
-HOMEPAGE="https://launchpad.net/keystone"
-SRC_URI="http://launchpad.net/${PN}/folsom/${PV}/+download/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="folsom"
-KEYWORDS="~amd64 ~x86"
-IUSE="+sqlite mysql postgres ldap"
-
-#todo, seperate out rdepend via use flags
-DEPEND=""
-RDEPEND="${DEPEND}
- dev-python/eventlet
- dev-python/greenlet
- dev-python/iso8601
- dev-python/lxml
- dev-python/passlib
- dev-python/paste
- dev-python/pastedeploy
- dev-python/python-daemon
- dev-python/python-pam
- dev-python/routes
- >=dev-python/sqlalchemy-migrate-0.7
- >=dev-python/webob-1.0.8
- virtual/python-argparse
- sqlite? ( dev-python/sqlalchemy[sqlite] )
- mysql? ( dev-python/sqlalchemy[mysql] )
- postgres? ( dev-python/sqlalchemy[postgres] )
- ldap? ( dev-python/python-ldap )
- ( || (
- sys-auth/keystone[sqlite]
- sys-auth/keystone[mysql]
- sys-auth/keystone[postgres]
- sys-auth/keystone[ldap]
- ) )
- "
-
-src_install() {
- distutils_src_install
- newconfd "${FILESDIR}/keystone.confd" keystone
- newinitd "${FILESDIR}/keystone.initd" keystone
-
- diropts -m 0750
- dodir /var/run/keystone /var/log/keystone /etc/keystone
- keepdir /etc/keystone
- insinto /etc/keystone
- doins etc/keystone.conf.sample etc/logging.conf.sample
- doins etc/default_catalog.templates etc/policy.json
-}