summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-07-09 21:01:22 +0000
committerPeter Volkov <pva@gentoo.org>2008-07-09 21:01:22 +0000
commit3476928382c37c8ab59849c0076aba20f75c96a9 (patch)
treedd50d91894d93fdfc536d674f7a8145d12b870e6 /net-dialup
parentNew package to test... (diff)
downloadpva-3476928382c37c8ab59849c0076aba20f75c96a9.tar.gz
pva-3476928382c37c8ab59849c0076aba20f75c96a9.tar.bz2
pva-3476928382c37c8ab59849c0076aba20f75c96a9.zip
this is great package, but a bit cleanup still required
svn path=/; revision=183
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/accel-pptp/Manifest2
-rw-r--r--net-dialup/accel-pptp/accel-pptp-0.7.13.ebuild88
-rw-r--r--net-dialup/accel-pptp/files/digest-accel-pptp-0.7.113
3 files changed, 93 insertions, 0 deletions
diff --git a/net-dialup/accel-pptp/Manifest b/net-dialup/accel-pptp/Manifest
new file mode 100644
index 0000000..315400a
--- /dev/null
+++ b/net-dialup/accel-pptp/Manifest
@@ -0,0 +1,2 @@
+DIST accel-pptp-0.7.13.tar.bz2 497254 RMD160 6a1754fd491947054e81c765aae0bb8b6cae94f0 SHA1 b7f691d54a099c9d6869ab449be5a97960045b02 SHA256 0f38af5ca161ba4842f192328dc083aedd6dc04adce1debf20fd2e23b2623d18
+EBUILD accel-pptp-0.7.13.ebuild 2248 RMD160 4ee97659a9c5c9a62eb2c4c9033ea8d7289de290 SHA1 3ae2661b2cdfdf8deea5ef7766212eb69adaa206 SHA256 18be3fb6587bb8bcec299e1c3a35b219d3230789545302cd73477f1a89c13969
diff --git a/net-dialup/accel-pptp/accel-pptp-0.7.13.ebuild b/net-dialup/accel-pptp/accel-pptp-0.7.13.ebuild
new file mode 100644
index 0000000..7d48034
--- /dev/null
+++ b/net-dialup/accel-pptp/accel-pptp-0.7.13.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpd/pptpd-1.3.1.ebuild,v 1.1 2006/03/26 09:13:06 mrness Exp $
+
+inherit linux-mod eutils autotools
+
+DESCRIPTION="Point-to-Point Tunnelling Protocol Client/Server for Linux"
+SRC_URI="mirror://sourceforge/accel-pptp/${P}.tar.bz2"
+HOMEPAGE="http://accel-pptp.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~amd64 ~x86"
+IUSE="tcpd server"
+
+DEPEND="server? ( !net-dialup/pptpd )
+ >=net-dialup/ppp-2.4.2
+ >=virtual/linux-sources-2.6.15
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="virtual/modutils"
+
+MODULE_NAMES="pptp(misc:${S}/kernel/driver)"
+BUILD_TARGETS="default"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+CONFIG_CHECK="PPP PPPOE"
+MODULESD_PPTP_EXAMPLES=("pptp min_window=5" "pptp max_window=50")
+MODULESD_PPTP_ALIASES=("net-pf-24 pptp")
+
+src_unpack() {
+ unpack ${A}
+
+ use server && cd "${S}"/pptpd-1.3.3 && eautoreconf
+ cd "${S}"/pppd_plugin && eautoreconf
+ convert_to_m "${S}"/kernel/driver/Makefile
+}
+
+src_compile() {
+ if use server; then
+ cd "${S}"/pptpd-1.3.3
+ econf --with-bcrelay \
+ $(use_with tcpd libwrap) || die "configure failed"
+ emake COPTS="${CFLAGS}" || die "make failed"
+ fi
+
+ cd "${S}"/pppd_plugin
+ econf || die "configure failed"
+ emake COPTS="${CFLAGS}" || die "make failed"
+
+ cd "${S}"/kernel/driver
+ linux-mod_src_compile || die "failed to build driver"
+}
+
+src_install () {
+ if use server; then
+ cd "${S}"/pptpd-1.3.3
+ einstall || die "make install failed"
+
+ insinto /etc
+ doins samples/pptpd.conf
+
+ insinto /etc/ppp
+ doins samples/options.pptpd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/pptpd-init" pptpd
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/pptpd-confd" pptpd
+ fi
+
+ cd "${S}"/pppd_plugin/src/.libs
+ local PPPD_VER=`best_version net-dialup/ppp`
+ PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
+ insinto /usr/lib/pppd/${PPPD_VER}
+ newins pptp.so.0.0.0 pptp.so
+
+ cd "${S}"/kernel/driver
+ linux-mod_src_install
+
+ cd "${S}"
+ dodoc README
+ cp -R example "${D}/usr/share/doc/${P}/exmaple"
+}
+
+pkg_postinst () {
+ modules-update
+}
diff --git a/net-dialup/accel-pptp/files/digest-accel-pptp-0.7.11 b/net-dialup/accel-pptp/files/digest-accel-pptp-0.7.11
new file mode 100644
index 0000000..b3ed5ca
--- /dev/null
+++ b/net-dialup/accel-pptp/files/digest-accel-pptp-0.7.11
@@ -0,0 +1,3 @@
+MD5 4e37388b1d8b5ab63dbec15310116c7a accel-pptp-0.7.11.tar.bz2 477428
+RMD160 93a6525087da40974a564e1dc86de39baa3c07de accel-pptp-0.7.11.tar.bz2 477428
+SHA256 6808a88f3415b8b55c34d82a0c382573f5f63d9bb66c446dcedd6546e2223501 accel-pptp-0.7.11.tar.bz2 477428