summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/libnasl/libnasl-2.2.11.ebuild')
-rw-r--r--net-analyzer/libnasl/libnasl-2.2.11.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/libnasl/libnasl-2.2.11.ebuild b/net-analyzer/libnasl/libnasl-2.2.11.ebuild
new file mode 100644
index 0000000..d346c53
--- /dev/null
+++ b/net-analyzer/libnasl/libnasl-2.2.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-2.2.9.ebuild,v 1.2 2007/04/11 13:50:23 welp Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A remote security scanner for Linux (libnasl)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="sys-devel/bison
+ doc? ( virtual/latex-base )
+ ~net-analyzer/nessus-libraries-${PV}"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ econf || die "configuration failed"
+ # emake fails for >= -j2. bug #16471. (we should generate cflags first)
+ emake -C nasl cflags
+ emake || die "make failed"
+ use doc && emake -C doc
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed libnasl"
+ use doc && dodoc doc/nasl_guide.ps
+}