summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-10-04 15:38:24 +0000
committerRichard Brown <rbrown@gentoo.org>2007-10-04 15:38:24 +0000
commit8108195f0a0f89938a4b0721453e65916f046f90 (patch)
treeb16b8aed7797847208bdaa87860ba61e1357480d
parentAdd fastercsv (diff)
downloadrbrown-8108195f0a0f89938a4b0721453e65916f046f90.tar.gz
rbrown-8108195f0a0f89938a4b0721453e65916f046f90.tar.bz2
rbrown-8108195f0a0f89938a4b0721453e65916f046f90.zip
Add DBD-ODBC and the current qpopper ebuild
svn path=/; revision=60
-rw-r--r--dev-perl/DBD-ODBC/DBD-ODBC-1.13.ebuild28
-rw-r--r--net-mail/qpopper/qpopper-4.0.5-r3.ebuild141
-rw-r--r--profiles/categories1
3 files changed, 170 insertions, 0 deletions
diff --git a/dev-perl/DBD-ODBC/DBD-ODBC-1.13.ebuild b/dev-perl/DBD-ODBC/DBD-ODBC-1.13.ebuild
new file mode 100644
index 0000000..104f9cc
--- /dev/null
+++ b/dev-perl/DBD-ODBC/DBD-ODBC-1.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# This ebuild generated by g-cpan 0.14.0
+
+inherit perl-module
+
+S=${WORKDIR}/DBD-ODBC-1.13
+
+DESCRIPTION="ODBC Driver for DBI"
+HOMEPAGE="http://search.cpan.org/search?query=${PN}"
+SRC_URI="mirror://cpan/authors/id/J/JU/JURL/DBD-ODBC-1.13.tar.gz"
+
+
+IUSE=""
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc sparc-fbsd x86 x86-fbsd"
+
+DEPEND="
+ >=dev-perl/DBI-1.53
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ export ODBCHOME="/usr"
+ perl-module_src_compile
+}
diff --git a/net-mail/qpopper/qpopper-4.0.5-r3.ebuild b/net-mail/qpopper/qpopper-4.0.5-r3.ebuild
new file mode 100644
index 0000000..87fb1ff
--- /dev/null
+++ b/net-mail/qpopper/qpopper-4.0.5-r3.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qpopper/qpopper-4.0.5-r3.ebuild,v 1.3 2007/06/12 13:06:20 genone Exp $
+
+inherit eutils
+
+IUSE="debug gdbm mailbox pam ssl xinetd"
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="A POP3 Server"
+SRC_URI="ftp://ftp.qualcomm.com/eudora/servers/unix/popper/${PN}${PV}.tar.gz
+ http://www.ibiblio.org/gentoo/distfiles/qpopper-files.tar.bz2"
+HOMEPAGE="http://www.eudora.com/products/unsupported/qpopper/index.html"
+
+DEPEND="virtual/mta
+ xinetd? ( virtual/inetd )
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( ~sys-libs/db-1.85 )
+ pam? (
+ >=sys-libs/pam-0.72
+ >=net-mail/mailbase-0.00-r8
+ )
+ ssl? ( dev-libs/openssl )"
+
+SLOT="0"
+LICENSE="qpopper"
+KEYWORDS="~amd64 sparc x86"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${PN}-CAN-2005-1151.patch" || die "first patch failed"
+ epatch "${FILESDIR}/${PN}-CAN-2005-1152.patch" || die "second patch failed"
+}
+
+src_compile() {
+ local myconf
+
+ use pam && myconf="${myconf} --with-pam=pop3"
+ use mailbox && myconf="${myconf} --enable-home-dir-mail=Mailbox"
+ use xinetd && myconf="${myconf} --disable-standalone" || \
+ myconf="${myconf} --enable-standalone"
+ myconf="${myconf} $(use_enable debug debugging)"
+ myconf="${myconf} $(use_with ssl openssl)"
+ myconf="${myconf} $(use_with gdbm)"
+ econf --enable-apop=/etc/pop.auth \
+ --enable-popuid=pop \
+ --enable-log-login \
+ --enable-specialauth \
+ --enable-log-facility=LOG_MAIL \
+ --enable-uw-kludge-flag \
+ ${myconf} || die "econf failed"
+
+ if use ssl; then
+ umask 077
+ PEM1=`/bin/mktemp ${T}/openssl.XXXXXX`
+ PEM2=`/bin/mktemp ${T}/openssl.XXXXXX`
+ /usr/bin/openssl req -newkey rsa:1024 -keyout $$PEM1 \
+ -nodes -x509 -days 365 -out $$PEM2 << EOF
+--
+SomeState
+SomeCity
+SomeOrganization
+SomeOrganizationalUnit
+localhost.localdomain
+root@localhost.localdomain
+EOF
+
+ cat $$PEM1 > cert.pem
+ echo "" >> cert.pem
+ cat $$PEM2 >> cert.pem
+ #make || die
+ rm $$PEM1 $$PEM2
+ umask 022
+
+ fi
+
+ if ! use gdbm; then
+ sed -i -e 's|#define HAVE_GDBM_H|//#define HAVE_GDBM_H|g' ${S}/config.h || \
+ die "sed failed"
+ fi
+
+ emake -j1 || die
+}
+
+src_install() {
+ into /usr
+ dosbin popper/popper popper/popauth
+
+ if use ssl; then
+ dodir /etc/mail/certs
+ fowners root:mail /etc/mail/certs
+ fperms 660 /etc/mail/certs
+ mv cert.pem ${D}/etc/mail/certs
+ fperms 600 /etc/mail/certs/cert.pem
+ fowners root:0 /etc/mail/certs/cert.pem
+ fi
+
+ doman man/popauth.8 man/popper.8
+
+ dodoc ${WORKDIR}/GUIDE.pdf
+
+ docinto rfc
+ dodoc doc/rfc*.txt
+
+ # pam.d stuff is provided by >=mailbase-0.00-r8. Bug #79240
+ # if use pam; then
+ # insinto /etc/pam.d
+ # newins ${WORKDIR}/pop3.pam-system-auth pop3
+ # fi
+
+ insinto /etc/xinetd.d
+ newins ${WORKDIR}/pop3.xinetd pop-3
+}
+
+pkg_postinst () {
+ elog "PS. If you use APOP service to authenticate "
+ elog "the users you have to follow these steps: "
+ elog ""
+ elog "1) create a new account named pop"
+ elog "2) change the owner and permissions of"
+ elog " /usr/sbin/popauth:"
+ elog " # chown pop /usr/sbin/popauth"
+ elog " # chmod u+s /usr/sbin/popauth"
+ elog "3) initialize the authentication database:"
+ elog " # popauth -init"
+ elog "4) new users can be added by root:"
+ elog " # popauth -user <user>"
+ elog " or removed:"
+ elog " # popauth -delete <user>"
+ elog " Other users can add themeselves or change their"
+ elog " password with the command popauth"
+ elog "5) scripts or other non-interactive processes can add or change"
+ elog " the passwords with the following command:"
+ elog " # popauth -user <user> <password>"
+ elog ""
+ elog "to enable qpopper in netkit-inetd just add this in one line"
+ elog "pop-3 stream tcp nowait root /usr/sbin/tcpd
+ /usr/sbin/in.qpopper -f /etc/qpopper.conf"
+ elog "into your /etc/inetd.conf"
+}
diff --git a/profiles/categories b/profiles/categories
index 32b1e10..7de3892 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -6,3 +6,4 @@ www-servers
sys-apps
dev-util
dev-perl
+net-mail