summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-06-19 15:31:41 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2015-06-19 15:31:41 +0000
commit05418a19d66543fb648d3c9e1a310bbde632c2d9 (patch)
treeff6ebc1b897c5ef1cd2ee4e6dc5a9ad77de9499f /x11-misc/xcoral
parentRemoved. (diff)
parentBump. (diff)
downloadrobbat2-05418a19d66543fb648d3c9e1a310bbde632c2d9.tar.gz
robbat2-05418a19d66543fb648d3c9e1a310bbde632c2d9.tar.bz2
robbat2-05418a19d66543fb648d3c9e1a310bbde632c2d9.zip
Merge branch 'master' of git+ssh://git.gentoo.org/dev/robbat2
Diffstat (limited to 'x11-misc/xcoral')
-rw-r--r--x11-misc/xcoral/Manifest3
-rw-r--r--x11-misc/xcoral/metadata.xml9
-rw-r--r--x11-misc/xcoral/xcoral-3.47.ebuild46
3 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/xcoral/Manifest b/x11-misc/xcoral/Manifest
new file mode 100644
index 0000000..9733e33
--- /dev/null
+++ b/x11-misc/xcoral/Manifest
@@ -0,0 +1,3 @@
+DIST xcoral-3.47.tar.gz 2760763 RMD160 57bef4965c17c616ce02f1e33455e7288893eeca SHA1 fc8231fde5a6f42c2c67498f818241c85db4f28d SHA256 886e02eeb96e494d32969fcf41dcd09133896b717b714eb42affed1f460af3dd
+EBUILD xcoral-3.47.ebuild 1024 RMD160 51a67012e9c1739e92edccc2a25bcea9bb4fa6a8 SHA1 4bacf1eb6dade174d7d4a885ac748c1bf84d8a20 SHA256 c266d3d4bad8d9e18fe43c132dcd7f08433262020beb81f5728b0735005b09ce
+MISC metadata.xml 237 RMD160 4a4eca320d9aecc995c605b3df4d050c2fc83e95 SHA1 8c8f6226b66ba06550ac98ae5b3c92d652176df9 SHA256 f2d82bf6c05a832179863f55e5eac69f12b716964d41c3844e3e012e1f2369d4
diff --git a/x11-misc/xcoral/metadata.xml b/x11-misc/xcoral/metadata.xml
new file mode 100644
index 0000000..3223a09
--- /dev/null
+++ b/x11-misc/xcoral/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/x11-misc/xcoral/xcoral-3.47.ebuild b/x11-misc/xcoral/xcoral-3.47.ebuild
new file mode 100644
index 0000000..ece2932
--- /dev/null
+++ b/x11-misc/xcoral/xcoral-3.47.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit eutils multilib
+
+DESCRIPTION="multiwindow mouse-based text editor for Unix and X Window System"
+HOMEPAGE="http://xcoral.free.fr/"
+SRC_URI="http://xcoral.free.fr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --with-x || die
+}
+
+XCORAL_SHAREDIR=/usr/share/xcoral
+
+src_compile() {
+ local makeopts="XCORALLIBDIR=\\\"${XCORAL_SHAREDIR}\\\""
+ # This avoids the parallel build weirdness.
+ # splitting the by build into 3 parts.
+ pushd "${S}/Smac"
+ # this is the only bit that isn't parallel safe itself
+ emake -j1 word.h y.tab.c ${makeopts} || die
+ # But we need to build the rest of the dir else it interacts weirdly with
+ # parallel.
+ emake all ${makeopts} || die
+ popd
+ # Last part.
+ emake ${makeopts} || die
+}
+
+src_install() {
+ dobin xcoral
+ dodoc README Doc/*pdf
+ insinto ${XCORAL_SHAREDIR}
+ doins SmacLib/*
+}