summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2009-03-17 10:08:06 +0000
committerAndreas Proschofsky <suka@gentoo.org>2009-03-17 10:08:06 +0000
commit5e39f75ae5391be13024c62385d03b129a8dd7de (patch)
tree2bc4c2e89c0052aeb6c6ef678bbeb76423787064
parentsvn path=/; revision=125 (diff)
downloadsuka-5e39f75ae5391be13024c62385d03b129a8dd7de.tar.gz
suka-5e39f75ae5391be13024c62385d03b129a8dd7de.tar.bz2
suka-5e39f75ae5391be13024c62385d03b129a8dd7de.zip
Move gwibber
svn path=/; revision=126
-rw-r--r--net-misc/gwibber/Manifest1
-rw-r--r--net-misc/gwibber/gwibber-9999.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/gwibber/Manifest b/net-misc/gwibber/Manifest
new file mode 100644
index 0000000..0a0f5ae
--- /dev/null
+++ b/net-misc/gwibber/Manifest
@@ -0,0 +1 @@
+EBUILD gwibber-9999.ebuild 1046 RMD160 f5651f7b50c0bbc554341ea518caf73714178d5b SHA1 cfaa049e2029ce323ef9f314f60013a39a945fc7 SHA256 d2c8d15fa88a877c199d213151636f25d9bf4ca1632466d317b02f95b01fc004
diff --git a/net-misc/gwibber/gwibber-9999.ebuild b/net-misc/gwibber/gwibber-9999.ebuild
new file mode 100644
index 0000000..ef1a2a9
--- /dev/null
+++ b/net-misc/gwibber/gwibber-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EBZR_BRANCH="trunk"
+EBZR_REPO_URI="https://code.launchpad.net/~gwibber-committers/gwibber/"
+inherit bzr
+
+DESCRIPTION="Gwibber is an open source microblogging client for GNOME developed with Python and GTK. It supports Twitter, Jaiku, Identi.ca, Facebook, and Digg."
+HOMEPAGE="https://launchpad.net/gwibber"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=dev-python/dbus-python-0.80.2
+ >=dev-python/gconf-python-2.18.0
+ >=dev-python/pygtk-2.10.4
+ >=dev-python/notify-python-0.1.1
+ dev-python/egenix-mx-base
+ dev-python/feedparser
+ >=dev-python/simplejson-1.7.3
+ >=dev-python/python-distutils-extra-1.91
+ net-libs/webkit-gtk
+ >=dev-python/pywebkitgtk-1.0.2"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd "${S}"
+ python setup.py config
+ python setup.py build || die "setup.py build failed"
+}
+
+src_install () {
+ python setup.py install --prefix=/usr --root="${D}"
+ assert "setup.py install failed"
+}
+