summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-12-11 12:21:38 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-12-11 12:21:38 +0000
commit14e9d39473322dda004473e05e05256a94113662 (patch)
treee33f9963ffa50565c0faa2fa43c2a657afda7ff0
parentFixed digests (diff)
downloadoverlay-14e9d39473322dda004473e05e05256a94113662.tar.gz
overlay-14e9d39473322dda004473e05e05256a94113662.tar.bz2
overlay-14e9d39473322dda004473e05e05256a94113662.zip
delicious-el fixed
svn path=/; revision=570
-rw-r--r--app-emacs/delicious/delicious-20051023.ebuild23
1 files changed, 18 insertions, 5 deletions
diff --git a/app-emacs/delicious/delicious-20051023.ebuild b/app-emacs/delicious/delicious-20051023.ebuild
index 7354f74..aa19a5b 100644
--- a/app-emacs/delicious/delicious-20051023.ebuild
+++ b/app-emacs/delicious/delicious-20051023.ebuild
@@ -4,17 +4,19 @@
inherit elisp
-IUSE=""
-
DESCRIPTION="Emacs client API for del.icio.us"
HOMEPAGE="http://www.wjsullivan.net/code/delicious-el.html"
SRC_URI="http://www.gunnarwrobel.de/downloads/${P}.tar.gz"
+
LICENSE="GPL-2"
-SLOT="0"
+IUSE="planner"
KEYWORDS="~x86"
+SLOT="0"
+
DEPEND="app-editors/emacs-cvs
- app-emacs/w3"
+ planner? ( app-emacs/planner
+ app-emacs/muse )"
SITEFILE=50delicious-gentoo.el
@@ -23,8 +25,19 @@ S="${WORKDIR}/${PN}-el"
src_compile() {
cd ${S}
+
+ local LOADPATH="/usr/share/emacs/22.0.50/lisp"
+ LOADPATH="${LOADPATH}:${S}"
+
+ if use planner; then
+ LOADPATH="${LOADPATH}:/usr/share/emacs/site-lisp/planner"
+ LOADPATH="${LOADPATH}:/usr/share/emacs/site-lisp/muse"
+ fi
+
+ local FILES="delicioapi.el delicious.el"
+ use planner && FILES="${FLIES} planner-delicious.el"
- EMACSLOADPATH="/usr/share/emacs/site-lisp/planner/:/usr/share/emacs/site-lisp/muse/:/usr/share/emacs/22.0.50/lisp/url/:${S}" elisp-compile *.el || die
+ EMACSLOADPATH="${LOADPATH}" elisp-compile *.el || die
}
src_install() {