summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-12-28 15:27:30 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-12-28 15:27:30 +0000
commit818d10ecd727594e5baa0cbf8bff246d845a111d (patch)
tree1b9c123f7f2b2170bafe84ef9bf289c64eae77b3
parentRemoved web-cyradm ebuild (diff)
downloadoverlay-818d10ecd727594e5baa0cbf8bff246d845a111d.tar.gz
overlay-818d10ecd727594e5baa0cbf8bff246d845a111d.tar.bz2
overlay-818d10ecd727594e5baa0cbf8bff246d845a111d.zip
Removed zope ebuild
svn path=/; revision=588
-rw-r--r--Makefile1
-rw-r--r--net-zope/zope/Manifest3
-rw-r--r--net-zope/zope/files/digest-zope-3.1.01
-rw-r--r--net-zope/zope/files/zope.initd61
-rw-r--r--net-zope/zope/zope-3.1.0.ebuild107
5 files changed, 0 insertions, 173 deletions
diff --git a/Makefile b/Makefile
index 8b66f24..ed7a082 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,6 @@ EBUILDS=app-admin/webapp-config/webapp-config-1.50.2.package \
dev-python/python-fuse/python-fuse-2.3.package \
net-fs/flickrfs/flickrfs-1.1.9.package \
net-news/nntprss/nntprss-0.5.2_beta.package \
- net-zope/zope/zope-3.1.0.package \
net-zope/zpkg/zpkg-1.0.0.package \
net-zope/contentprovider/contentprovider-20051102.package \
net-zope/viewlet/viewlet-20051102.package \
diff --git a/net-zope/zope/Manifest b/net-zope/zope/Manifest
deleted file mode 100644
index b6f1b84..0000000
--- a/net-zope/zope/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 fc4481b581588f572e649944b299c014 zope-3.1.0.ebuild 2434
-MD5 af9f7a9e66ce59bf1a8a901402f6ed5e files/digest-zope-3.1.0 60
-MD5 dc6beeaa42a91779d1d707dcd32cc6cb files/zope.initd 1316
diff --git a/net-zope/zope/files/digest-zope-3.1.0 b/net-zope/zope/files/digest-zope-3.1.0
deleted file mode 100644
index da477df..0000000
--- a/net-zope/zope/files/digest-zope-3.1.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7e4c383479753639cddb14e2914582eb Zope-3.1.0.tgz 4048336
diff --git a/net-zope/zope/files/zope.initd b/net-zope/zope/files/zope.initd
deleted file mode 100644
index 4f1e007..0000000
--- a/net-zope/zope/files/zope.initd
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zopex3/files/zope.initd,v 1.2 2004/09/28 01:47:28 swegener Exp $
-
-opts="start stop restart kill quit status help"
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting Zope in INSTANCE_HOME"
- INSTANCE_HOME/bin/zopectl start
- eend $?
-}
-
-stop() {
- ebegin "Stopping Zope in INSTANCE_HOME"
- INSTANCE_HOME/bin/zopectl stop
- eend $?
-}
-
-restart() {
- ebegin "Restarting Zope in INSTANCE_HOME"
- svc_stop
- svc_start
- eend $?
-}
-
-kill() {
- ebegin "Killing Zope in INSTANCE_HOME"
- INSTANCE_HOME/bin/zopectl kill
- eend $?
-}
-
-quit() {
- ebegin "Quitting Zope Daemon Manager INSTANCE_HOME"
- INSTANCE_HOME/bin/zopectl quit
- eend $?
-}
-
-reload() {
- # throws an error, dunno why
- ebegin "Reloading Zope config in INSTANCE_HOME"
- INSTANCE_HOME/bin/zopectl reload
- eend $?
-}
-
-status() {
- ebegin "Status of Zope in INSTANCE_HOME"
- INSTANCE_HOME/bin/zopectl status
- eend $?
-}
-
-help() {
- ebegin "Help for Zope Daemon Manager in INSTANCE_HOME"
- INSTANCE_HOME/bin/zopectl help
- eend $?
-}
-
diff --git a/net-zope/zope/zope-3.1.0.ebuild b/net-zope/zope/zope-3.1.0.ebuild
deleted file mode 100644
index d4926b5..0000000
--- a/net-zope/zope/zope-3.1.0.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils multilib
-
-DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites."
-HOMEPAGE="http://www.zope.org"
-SRC_URI="http://www.zope.org/Products/Zope3/${PV}final/Zope-${PV}.tgz"
-
-LICENSE="ZPL"
-SLOT="${PV}"
-IUSE=""
-
-KEYWORDS="~x86"
-
-RDEPEND="=dev-lang/python-2.4*"
-python='python2.4'
-
-DEPEND="${RDEPEND}
-virtual/libc
->=sys-apps/sed-4.0.5"
-
-S="${WORKDIR}/Zope-${PV}"
-
-ZS_DIR=${ROOT%/}/usr/$(get_libdir)
-ZSERVDIR=${ZS_DIR}/${P}
-ZSKELDIR=${ZSERVDIR}/zopeskel
-ZINSTDIR=/var/lib/zope/${PN}
-
-src_compile() {
-
- cd ${S}
-
- ./configure --prefix=${D}${ZSERVDIR} --with-python=/usr/bin/python2.4 || die "Failed to configure."
- emake || die "Failed to compile."
-}
-
-src_install() {
-
- cd ${S}
-
- dodoc README.txt
- dodoc Zope/doc/*.txt
- for DIR in schema security skins style zcml zsync
- do
- docinto ${DIR}
- dodoc Zope/doc/${DIR}/*
- done
-
- make install prefix=${D}${ZSERVDIR}
-
- dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
-
- # copy the init script skeleton to zopeskel directory of our installation
- cp ${FILESDIR}/zope.initd ${D}${ZSKELDIR}/zope.initd
-}
-
-pkg_postinst() {
-
- einfo
- einfo "This release can create a default instance using the command: emerge --config =${PF}"
- einfo
-}
-
-pkg_prerm() {
-
- find ${ZSERVDIR}/lib/python -name \*.py[co] -exec rm -f {} \;
-}
-
-pkg_postrm() {
-
- rmdir /usr/lib/${ZSERVDIR} 2>/dev/null
-}
-
-pkg_config() {
-
- if [ -f /etc/init.d/${PN} -o -d ${ZINSTDIR} ]
- then
- ewarn "Default instance already exists, aborting.."
- ewarn "Please delete first /etc/init.d/${PN} and ${ZINSTDIR}"
- die "Failed to create default instance."
- fi
-
- mkdir -p ${ZINSTDIR}
- ${ZSERVDIR}/bin/mkzopeinstance -d ${ZINSTDIR} -u admin:admin
-
- # remove unnecessary zope.initd
- rm -f ${ZINSTDIR}/zope.initd
-
- # log symlink
- rm -rf ${ZINSTDIR}/log
- mkdir -p /var/log/zope/${PN}
- ln -s /var/log/zope/${PN} ${ZINSTDIR}/log
-
- # draconian permissions :)
- chmod go-rwx -R ${ZINSTDIR}
-
- cp ${ZSKELDIR}/zope.initd /etc/init.d/${PN}
- chmod 755 /etc/init.d/${PN}
- sed -i -e "s|INSTANCE_HOME|${ZINSTDIR}|" /etc/init.d/${PN}
-
- einfo "Default instance created at ${ZINSTDIR}"
- einfo "Created default user 'admin' with password 'admin'."
- einfo "Be warned that this instance is prepared to run as root only."
- einfo "To start instance (ports 8080,8021,) use: /etc/init.d/${PN} start"
-}