summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2011-06-12 11:01:48 +0200
committerKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2011-06-12 11:01:48 +0200
commit042b4a0967480c0b08f6604bf764642893243c46 (patch)
treea2a552e4061874e49e10ad50aa38b81dcf53758d
parent[dev-python/python-xcaplib] initial import (diff)
downloadxarthisius-042b4a0967480c0b08f6604bf764642893243c46.tar.gz
xarthisius-042b4a0967480c0b08f6604bf764642893243c46.tar.bz2
xarthisius-042b4a0967480c0b08f6604bf764642893243c46.zip
[dev-python/python-cjson] initial import
-rw-r--r--dev-python/python-cjson/Manifest3
-rw-r--r--dev-python/python-cjson/metadata.xml16
-rw-r--r--dev-python/python-cjson/python-cjson-1.0.5.ebuild27
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-cjson/Manifest b/dev-python/python-cjson/Manifest
new file mode 100644
index 0000000..d1b7e4f
--- /dev/null
+++ b/dev-python/python-cjson/Manifest
@@ -0,0 +1,3 @@
+DIST python-cjson-1.0.5.tar.gz 10978 RMD160 c1256cf176af3194233de3704ec07ab4ccfb522c SHA1 a00519debfdc6dcc33acfe68dc10ee4866fdcd8b SHA256 85bbe7a9fb6617e24bb4dbef528af8ef6eae07f8809dcd05ec926142feca7714
+EBUILD python-cjson-1.0.5.ebuild 624 RMD160 4101272abf2e3d66bd8b6601b0a2542f903884d1 SHA1 59898e299e5abd12c96107500fe3e727391e5aed SHA256 f6628756cda1f629cd976ba27293ddf8f3c702d4c0f560ef370ea5f3be3ceb12
+MISC metadata.xml 648 RMD160 052e13a4f74f90dd9168c34ee21f40caf182a1e3 SHA1 9c09c5b99852b3614ae31f22b8e8de159612ae13 SHA256 a5c4004bd76204da84130291d82f4130cf662b5fc4fca800437df5e3c2c1979c
diff --git a/dev-python/python-cjson/metadata.xml b/dev-python/python-cjson/metadata.xml
new file mode 100644
index 0000000..e9e02fd
--- /dev/null
+++ b/dev-python/python-cjson/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+ <longdescription>
+ The module is written in C and it is up to 250 times faster when compared to
+ the other python JSON implementations which are written directly in python.
+ This speed gain varies with the complexity of the data and the operation and
+ is the the range of 10-200 times for encoding operations and in the range of
+ 100-250 times for decoding operations.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-cjson/python-cjson-1.0.5.ebuild b/dev-python/python-cjson/python-cjson-1.0.5.ebuild
new file mode 100644
index 0000000..9f692f0
--- /dev/null
+++ b/dev-python/python-cjson/python-cjson-1.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Very fast JSON encoder/decoder for Python"
+HOMEPAGE="http://pypi.python.org/pypi/python-cjson/
+ http://ag-projects.com/"
+SRC_URI="http://pypi.python.org/packages/source/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" jsontest.py
+ }
+ python_execute_function testing
+}