summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2006-07-12 15:32:45 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2006-07-12 15:32:45 +0000
commit8ea086048456069c656fb2811223f9f227a6a28f (patch)
tree0bdc564cbceadc54cfe05a650bdae725a2844b0b /media-video/istanbul-cvs/istanbul-cvs-0.1.999.ebuild
parentadded gst-plugins-pulse (diff)
downloadzaheerm-8ea086048456069c656fb2811223f9f227a6a28f.tar.gz
zaheerm-8ea086048456069c656fb2811223f9f227a6a28f.tar.bz2
zaheerm-8ea086048456069c656fb2811223f9f227a6a28f.zip
Added istanbul cvs ebuilds
svn path=/; revision=2
Diffstat (limited to 'media-video/istanbul-cvs/istanbul-cvs-0.1.999.ebuild')
-rw-r--r--media-video/istanbul-cvs/istanbul-cvs-0.1.999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-video/istanbul-cvs/istanbul-cvs-0.1.999.ebuild b/media-video/istanbul-cvs/istanbul-cvs-0.1.999.ebuild
new file mode 100644
index 0000000..dfe7cbd
--- /dev/null
+++ b/media-video/istanbul-cvs/istanbul-cvs-0.1.999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-libmms/gst-plugins-libmms-0.10.0.ebuild,v 1.2 2006/04/04 15:04:40 mr_bones_ Exp $
+
+inherit gnome2 eutils cvs
+
+ECVS_ANON="yes"
+ECVS_CVS_OPTIONS="-dP"
+ECVS_SERVER="anoncvs.gnome.org:/cvs/gnome"
+ECVS_MODULE="istanbul"
+ECVS_BRANCH="HEAD"
+
+KEYWORDS="~x86"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.8
+ >=media-plugins/gst-plugins-ximagesrc-cvs-0.10.0
+ dev-lang/python
+ >=dev-python/pygtk-2.6
+ >=dev-python/gnome-python-extras-2.11.3
+ media-plugins/gst-plugins-ogg
+ media-plugins/gst-plugins-theora
+ >=media-libs/libtheora-1.0_alpha6"
+
+DEPEND="${RDEPEND}"
+SRC_URI=""
+S="${WORKDIR}/${ECVS_MODULE}"
+
+src_unpack() {
+ cvs_src_unpack
+}
+
+src_compile() {
+ mkdir -p "${T}/home"
+ export HOME="${T}/home"
+ export GST_REGISTRY=${T}/home/registry.cache.xml
+ addpredict /root/.gconfd
+ addpredict /root/.gconf
+ cd ${S}
+ ./autogen.sh || die "autogen.sh failed"
+ emake
+}