aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2021-01-27 11:16:15 +0100
committerGitHub <noreply@github.com>2021-01-27 11:16:15 +0100
commit6790005a9a30ae3eca69d1957fb072171643a366 (patch)
tree3648e7157062c53950042666b3e7aee99960715d
parentbpo-43033: Fix the handling of PyObject_SetAttrString() in _zoneinfo.c (GH-24... (diff)
downloadcpython-6790005a9a30ae3eca69d1957fb072171643a366.tar.gz
cpython-6790005a9a30ae3eca69d1957fb072171643a366.tar.bz2
cpython-6790005a9a30ae3eca69d1957fb072171643a366.zip
bpo-43031: Set a timeout when running tests in PGO build (GH-24339)
Pass --timeout=$(TESTTIMEOUT) option to the default profile task "./python -m test --pgo" command.
-rw-r--r--Misc/NEWS.d/next/Build/2021-01-26-14-48-40.bpo-43031.44nK9U.rst2
-rwxr-xr-xconfigure2
-rw-r--r--configure.ac2
3 files changed, 4 insertions, 2 deletions
diff --git a/Misc/NEWS.d/next/Build/2021-01-26-14-48-40.bpo-43031.44nK9U.rst b/Misc/NEWS.d/next/Build/2021-01-26-14-48-40.bpo-43031.44nK9U.rst
new file mode 100644
index 00000000000..6e8377fb306
--- /dev/null
+++ b/Misc/NEWS.d/next/Build/2021-01-26-14-48-40.bpo-43031.44nK9U.rst
@@ -0,0 +1,2 @@
+Pass ``--timeout=$(TESTTIMEOUT)`` option to the default profile task
+``./python -m test --pgo`` command.
diff --git a/configure b/configure
index 37ee3691bb6..39fb15f5c79 100755
--- a/configure
+++ b/configure
@@ -6532,7 +6532,7 @@ fi
$as_echo_n "checking PROFILE_TASK... " >&6; }
if test -z "$PROFILE_TASK"
then
- PROFILE_TASK='-m test --pgo'
+ PROFILE_TASK='-m test --pgo --timeout=$(TESTTIMEOUT)'
fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $PROFILE_TASK" >&5
$as_echo "$PROFILE_TASK" >&6; }
diff --git a/configure.ac b/configure.ac
index 99077e9c3a9..1f5a008388a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1325,7 +1325,7 @@ AC_ARG_VAR(PROFILE_TASK, Python args for PGO generation task)
AC_MSG_CHECKING(PROFILE_TASK)
if test -z "$PROFILE_TASK"
then
- PROFILE_TASK='-m test --pgo'
+ PROFILE_TASK='-m test --pgo --timeout=$(TESTTIMEOUT)'
fi
AC_MSG_RESULT($PROFILE_TASK)