aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Picus <matti.picus@gmail.com>2020-12-20 04:56:57 +0200
committerGitHub <noreply@github.com>2020-12-20 02:56:57 +0000
commita44ce6c9f725d336aea51a946b42769f29fed613 (patch)
treec8e4e53f45c192e363511ed45e3e79b729fc5a6e
parentbpo-41724: Explain when the conversion is not possible with detect_types enab... (diff)
downloadcpython-a44ce6c9f725d336aea51a946b42769f29fed613.tar.gz
cpython-a44ce6c9f725d336aea51a946b42769f29fed613.tar.bz2
cpython-a44ce6c9f725d336aea51a946b42769f29fed613.zip
bpo-42604: always set EXT_SUFFIX=${SOABI}${SHLIB_SUFFIX} when using configure (GH-23708)
Now all platforms use a value for the "EXT_SUFFIX" build variable derived from SOABI (for instance in FreeBSD, "EXT_SUFFIX" is now ".cpython-310d.so" instead of ".so"). Previously only Linux, Mac and VxWorks were using a value for "EXT_SUFFIX" that included "SOABI". Co-authored-by: Pablo Galindo <pablogsal@gmail.com>
-rw-r--r--Misc/NEWS.d/next/Build/2020-12-20-02-35-28.bpo-42604.gRd89w.rst4
-rwxr-xr-xconfigure8
-rw-r--r--configure.ac7
3 files changed, 6 insertions, 13 deletions
diff --git a/Misc/NEWS.d/next/Build/2020-12-20-02-35-28.bpo-42604.gRd89w.rst b/Misc/NEWS.d/next/Build/2020-12-20-02-35-28.bpo-42604.gRd89w.rst
new file mode 100644
index 00000000000..caaada41cf9
--- /dev/null
+++ b/Misc/NEWS.d/next/Build/2020-12-20-02-35-28.bpo-42604.gRd89w.rst
@@ -0,0 +1,4 @@
+Now all platforms use a value for the "EXT_SUFFIX" build variable derived
+from SOABI (for instance in freeBSD, "EXT_SUFFIX" is now ".cpython-310d.so"
+instead of ".so"). Previosuly only Linux, Mac and VxWorks were using a value
+for "EXT_SUFFIX" that included "SOABI".
diff --git a/configure b/configure
index d9e610ea4d0..f07edfff266 100755
--- a/configure
+++ b/configure
@@ -15429,13 +15429,7 @@ _ACEOF
fi
-
-case $ac_sys_system in
- Linux*|GNU*|Darwin|VxWorks)
- EXT_SUFFIX=.${SOABI}${SHLIB_SUFFIX};;
- *)
- EXT_SUFFIX=${SHLIB_SUFFIX};;
-esac
+EXT_SUFFIX=.${SOABI}${SHLIB_SUFFIX}
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking LDVERSION" >&5
$as_echo_n "checking LDVERSION... " >&6; }
diff --git a/configure.ac b/configure.ac
index 445dae13587..ee5573cf644 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4786,12 +4786,7 @@ if test "$Py_DEBUG" = 'true' -a "$with_trace_refs" != "yes"; then
fi
AC_SUBST(EXT_SUFFIX)
-case $ac_sys_system in
- Linux*|GNU*|Darwin|VxWorks)
- EXT_SUFFIX=.${SOABI}${SHLIB_SUFFIX};;
- *)
- EXT_SUFFIX=${SHLIB_SUFFIX};;
-esac
+EXT_SUFFIX=.${SOABI}${SHLIB_SUFFIX}
AC_MSG_CHECKING(LDVERSION)
LDVERSION='$(VERSION)$(ABIFLAGS)'