aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2018-04-19 20:21:33 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2018-04-19 20:24:36 +0200
commite60c3f2bb71210ca62dc09b1b797443a88b4e3cf (patch)
tree50147302128a6f8518d75321079f311e39bd61f9 /bits/sched.h
parentFix mips64n32 getdents alias (diff)
downloadglibc-e60c3f2bb71210ca62dc09b1b797443a88b4e3cf.tar.gz
glibc-e60c3f2bb71210ca62dc09b1b797443a88b4e3cf.tar.bz2
glibc-e60c3f2bb71210ca62dc09b1b797443a88b4e3cf.zip
hurd: Avoid exposing all <sched.h> symbols from sys/types.h
* bits/sched.h: Include <bits/types/struct_sched_param.h> and move struct sched_param definition to it. * sysdeps/unix/sysv/linux/bits/sched.h: Likewise. * bits/types/struct_sched_param.h: New file. * sysdeps/htl/bits/types/struct___pthread_attr.h: Include <bits/types/struct_sched_param.h> instead of <sched.h>. * posix/Makefile (headers): Add bits/types/struct_sched_param.h.
Diffstat (limited to 'bits/sched.h')
-rw-r--r--bits/sched.h6
1 files changed, 1 insertions, 5 deletions
diff --git a/bits/sched.h b/bits/sched.h
index 8d9f077eee..bdd94c969d 100644
--- a/bits/sched.h
+++ b/bits/sched.h
@@ -29,10 +29,6 @@
#define SCHED_FIFO 1
#define SCHED_RR 2
-/* Data structure to describe a process' schedulability. */
-struct sched_param
-{
- int sched_priority;
-};
+#include <bits/types/struct_sched_param.h>
#endif /* bits/sched.h */