aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Lin <jim@andestech.com>2021-04-12 14:04:38 +0800
committerJim Lin <jim@andestech.com>2021-04-12 14:05:37 +0800
commitdd4c999c2316288f7c560f5c18077642c14b50df (patch)
treeb3e71bcb9df7f3a2c0a72fbe428663cd8090e4cb
parent[X86] Pass to transform tdpbsud&tdpbusd&tdpbuud intrinsics to scalar operation (diff)
downloadllvm-project-dd4c999c2316288f7c560f5c18077642c14b50df.tar.gz
llvm-project-dd4c999c2316288f7c560f5c18077642c14b50df.tar.bz2
llvm-project-dd4c999c2316288f7c560f5c18077642c14b50df.zip
fix typo in a CMake SANITIZER_CAN_USE_CXXABI variable initial definition
The current variable name isn't used anywhere else, which indicates it's a typo. Let's fix it before someone copy+pastes it somewhere else. Reviewed By: Jim Differential Revision: https://reviews.llvm.org/D39157
-rw-r--r--compiler-rt/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/compiler-rt/CMakeLists.txt b/compiler-rt/CMakeLists.txt
index b6cbcea91f5a..2d5fd9cc4d81 100644
--- a/compiler-rt/CMakeLists.txt
+++ b/compiler-rt/CMakeLists.txt
@@ -173,7 +173,7 @@ endif()
option(SANITIZER_ALLOW_CXXABI "Allow use of C++ ABI details in ubsan" ON)
-set(SANITIZE_CAN_USE_CXXABI OFF)
+set(SANITIZER_CAN_USE_CXXABI OFF)
if (cxxabi_supported AND SANITIZER_ALLOW_CXXABI)
set(SANITIZER_CAN_USE_CXXABI ON)
endif()