summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/x264/files/x264-onlylib-20110425.patch')
-rw-r--r--media-libs/x264/files/x264-onlylib-20110425.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/x264/files/x264-onlylib-20110425.patch b/media-libs/x264/files/x264-onlylib-20110425.patch
new file mode 100644
index 0000000..6f216b9
--- /dev/null
+++ b/media-libs/x264/files/x264-onlylib-20110425.patch
@@ -0,0 +1,30 @@
+Index: x264-snapshot-20110425-2245/Makefile
+===================================================================
+--- x264-snapshot-20110425-2245.orig/Makefile
++++ x264-snapshot-20110425-2245/Makefile
+@@ -137,7 +137,7 @@ DEP = depend
+
+ .PHONY: all default fprofiled clean distclean install uninstall dox test testclean
+
+-default: $(DEP) x264$(EXE)
++default: $(DEP)
+
+ $(LIBX264): .depend $(OBJS) $(OBJASM)
+ $(AR)$@ $(OBJS) $(OBJASM)
+@@ -207,7 +207,7 @@ distclean: clean
+ rm -f config.mak x264_config.h config.h config.log x264.pc x264.def
+ rm -rf test/
+
+-install: x264$(EXE) $(SONAME)
++install: $(LIBX264) $(SONAME)
+ install -d $(DESTDIR)$(bindir)
+ install -d $(DESTDIR)$(includedir)
+ install -d $(DESTDIR)$(libdir)
+@@ -216,7 +216,6 @@ install: x264$(EXE) $(SONAME)
+ install -m 644 x264_config.h $(DESTDIR)$(includedir)
+ install -m 644 $(LIBX264) $(DESTDIR)$(libdir)
+ install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
+- install x264$(EXE) $(DESTDIR)$(bindir)
+ $(if $(RANLIB), $(RANLIB) $(DESTDIR)$(libdir)/$(LIBX264))
+ ifeq ($(SYS),WINDOWS)
+ $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))