aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Bersenev <bay@hackerdom.ru>2011-08-21 17:38:24 +0000
committerAlexander Bersenev <bay@hackerdom.ru>2011-08-21 17:38:24 +0000
commit4161e981fd764f039fec2fff2afe3af380d33b83 (patch)
treeb4d5965e4944a5a62a3fe4a4fc68e56bad71787e
parentadd a patched version of portage (diff)
downloadautodep-4161e981fd764f039fec2fff2afe3af380d33b83.tar.gz
autodep-4161e981fd764f039fec2fff2afe3af380d33b83.tar.bz2
autodep-4161e981fd764f039fec2fff2afe3af380d33b83.zip
first version of toplevel makefile
-rw-r--r--Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..96e3763
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,15 @@
+all: hookfs file_hook.so
+
+hookfs: src/hook_fusefs/hookfs.c
+ $(CC) -std=c99 -Wall `pkg-config fuse --cflags --libs` -lulockmgr \
+ $(CFLAGS) $(LDFLAGS) src/hook_fusefs/hookfs.c -o hookfs
+
+file_hook.so: file_hook.o
+ ld -shared -o file_hook.so -ldl -lc file_hook.o
+
+file_hook.o: src/hook_lib/file_hook.c
+ cc -Wall -fPIC -o file_hook.o -c src/hook_lib/file_hook.c
+
+
+clean:
+ rm -f hookfs file_hook.o file_hook.so