aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'autodep_overlay/app-portage/autodep/autodep-0.4.ebuild')
-rw-r--r--autodep_overlay/app-portage/autodep/autodep-0.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/autodep_overlay/app-portage/autodep/autodep-0.4.ebuild b/autodep_overlay/app-portage/autodep/autodep-0.4.ebuild
new file mode 100644
index 0000000..92ce5ba
--- /dev/null
+++ b/autodep_overlay/app-portage/autodep/autodep-0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
+
+inherit autotools eutils python flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Auto dependency analyser for Gentoo"
+HOMEPAGE="http://soc.dev.gentoo.org/~bay/autodep/"
+SRC_URI="http://soc.dev.gentoo.org/~bay/autodep/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="
+ app-portage/portage-utils
+ sys-fs/fuse"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" RAW_LDFLAGS="$(raw-ldflags)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" libdir="$(get_libdir)" install || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/portage_with_autodep
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/portage_with_autodep
+}
+