summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-09-27 15:49:21 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-09-27 15:56:35 -0500
commita3e35578740551f78a8fa44b51143865ca16c4a9 (patch)
tree63cc721b70c82faeb2d2ff74549e410ac85fa509
parentdrop lib directory installation from Makefile (diff)
downloadbaselayout-a3e35578.tar.gz
baselayout-a3e35578.tar.bz2
baselayout-a3e35578.zip
clean up makefile
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index aaae44ad..8c6f026f 100644
--- a/Makefile
+++ b/Makefile
@@ -64,10 +64,13 @@ install:
$(INSTALL_DIR) $(DESTDIR)/etc
cp -pPR etc/* etc.$(OS)/* $(DESTDIR)/etc/
echo "Gentoo Base System release ${PV}" > ${DESTDIR}/etc/gentoo-release
+ $(INSTALL_DIR) $(DESTDIR)/lib
+ cp -pPR lib.$(OS)/* $(DESTDIR)/etc/
+ $(INSTALL_DIR) $(DESTDIR)/usr/lib
+ ln -snf ../usr/lib/os-release ${DESTDIR}/etc/os-release
+ ./make_os_release ${OS} ${PV} > $(DESTDIR)/usr/lib/os-release
$(INSTALL_DIR) $(DESTDIR)/usr/share/baselayout
cp -pPR share.$(OS)/* $(DESTDIR)/usr/share/baselayout/
- ./make_os_release $(OS) $(PV) > $(DESTDIR)/usr/lib/os-release
- ln -snf ../usr/lib/os-release ${DESTDIR}/etc/os-release
layout-dirs:
# Create base filesytem layout