summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-25 18:05:18 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-25 18:05:18 -0600
commitcd2a6014247b4a3b69b780a331e4d5a5f280c2d8 (patch)
treee747bd583b844eb1be159ea5ddda3f495d608f36
parentdrop .keep files in layout target (diff)
downloadbaselayout-cd2a6014.tar.gz
baselayout-cd2a6014.tar.bz2
baselayout-cd2a6014.zip
drop fhs compatibility symlinks from the makefile
This is necessary since we want baselayout to own these links. To do that, we need to create them in the ebuild. Bug: https://bugs.gentoo.org/648880 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--Makefile5
1 files changed, 0 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 22e4a174..ecc7b107 100644
--- a/Makefile
+++ b/Makefile
@@ -66,15 +66,10 @@ layout:
for x in $(KEEP_DIRS) ; do \
$(INSTALL_DIR) $(DESTDIR)$$x ; \
done
- ln -snf /proc/self/mounts $(DESTDIR)/etc/mtab
- ln -snf /run $(DESTDIR)/var/run
- ln -snf /run/lock $(DESTDIR)/var/lock
# Special dirs
chmod 0700 $(DESTDIR)/root
chmod 1777 $(DESTDIR)/var/tmp
chmod 1777 $(DESTDIR)/tmp
- # FHS compatibility symlinks stuff
- ln -snf /var/tmp $(DESTDIR)/usr/tmp
layout-usrmerge: layout
rm -fr ${DESTDIR}/bin