summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-11-17 16:03:50 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-11-17 16:03:50 -0600
commit77e9c6f275399cdef64d432a19da51bc9c9cd0bf (patch)
tree932d25dc24fdeed986a1f144f35c6b98b4fb15f5 /Makefile
parentDrop support for ROOTPATH (diff)
downloadbaselayout-77e9c6f275399cdef64d432a19da51bc9c9cd0bf.tar.gz
baselayout-77e9c6f275399cdef64d432a19da51bc9c9cd0bf.tar.bz2
baselayout-77e9c6f275399cdef64d432a19da51bc9c9cd0bf.zip
add layout-usrmerge to optionally support the /usr merge
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 9181c7d7..966e71ac 100644
--- a/Makefile
+++ b/Makefile
@@ -90,6 +90,11 @@ layout: layout-dirs layout-$(OS)
# FHS compatibility symlinks stuff
ln -snf /var/tmp $(DESTDIR)/usr/tmp
+layout-usrmerge: layout
+ ln -snf usr/bin ${DESTDIR}/bin
+ ln -snf usr/sbin ${DESTDIR}/sbin
+ ln -snf bin ${DESTDIR}/usr/sbin
+
live:
rm -rf /tmp/$(PKG)
cp -r . /tmp/$(PKG)