summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog2
-rw-r--r--etc/Makefile2
-rw-r--r--etc/env.d/00basic2
-rw-r--r--etc/profile5
-rw-r--r--etc/profile.d/Makefile4
-rw-r--r--etc/rc.conf7
6 files changed, 8 insertions, 14 deletions
diff --git a/ChangeLog b/ChangeLog
index 657182a4..b47e529d 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -5,6 +5,8 @@
Make sure we list all config files in rc help output.
+ Punt PAGER and EDITOR. People need to set this themselves now.
+
22 Aug 2007; Roy Marples <uberlord@gentoo.org>:
Only open /proc/cmdline if it exists, #189686 thanks to Christian Affolter.
diff --git a/etc/Makefile b/etc/Makefile
index 190239ec..d93220f3 100644
--- a/etc/Makefile
+++ b/etc/Makefile
@@ -1,4 +1,4 @@
-SUBDIRS = env.d
+SUBDIRS = env.d profile.d
DIR = /etc
FILES = hosts networks profile protocols rc.conf services shells
diff --git a/etc/env.d/00basic b/etc/env.d/00basic
index d19d5401..65f3b01e 100644
--- a/etc/env.d/00basic
+++ b/etc/env.d/00basic
@@ -6,5 +6,3 @@ LDPATH="/usr/local/lib"
MANPATH="/usr/local/share/man:/usr/share/man"
INFOPATH="/usr/share/info"
CVS_RSH="ssh"
-PAGER="/usr/bin/less"
-LESSOPEN="|lesspipe.sh %s"
diff --git a/etc/profile b/etc/profile
index 27d6b4d1..233f0d32 100644
--- a/etc/profile
+++ b/etc/profile
@@ -29,11 +29,6 @@ fi
export PATH
unset ROOTPATH
-# Extract the value of EDITOR
-[ -z "$EDITOR" ] && EDITOR="`. /etc/rc.conf 2>/dev/null; echo $EDITOR`"
-[ -z "$EDITOR" ] && EDITOR="/bin/nano"
-export EDITOR
-
if [ -n "${BASH_VERSION}" ] ; then
# Newer bash ebuilds include /etc/bash/bashrc which will setup PS1
# including color. We leave out color here because not all
diff --git a/etc/profile.d/Makefile b/etc/profile.d/Makefile
new file mode 100644
index 00000000..abc1841d
--- /dev/null
+++ b/etc/profile.d/Makefile
@@ -0,0 +1,4 @@
+DIR = /etc/profile.d
+
+TOPDIR = ../..
+include $(TOPDIR)/default.mk
diff --git a/etc/rc.conf b/etc/rc.conf
index 482acddc..0a65eb02 100644
--- a/etc/rc.conf
+++ b/etc/rc.conf
@@ -6,12 +6,7 @@
UNICODE="no"
-# Set EDITOR to your preferred editor.
-# You may use something other than what is listed here.
-
-EDITOR="/bin/nano"
-#EDITOR="/usr/bin/vim"
-#EDITOR="/usr/bin/emacs"
+# You should set EDITOR and PAGER in a file in /etc/profile.d/ like "base.sh".
# XSESSION is a new variable to control what window manager to start
# default with X if run with xdm, startx or xinit. The default behavior