summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-03-19 01:50:21 +0100
committerSebastian Pipping <sping@gentoo.org>2017-03-19 03:08:04 +0100
commite89c1a31f82512c00ea665392b3e10d62d8a91d8 (patch)
treefd16c0f219c0fbaf420889e4eb2cd0fda4d46e2f
parentdev-python/rinoh-typeface-dejavuserif: 0.1.1 (diff)
downloadbetagarden-e89c1a31.tar.gz
betagarden-e89c1a31.tar.bz2
betagarden-e89c1a31.zip
app-text/rinohtype: 0.3.1
-rw-r--r--app-text/rinohtype/Manifest1
-rw-r--r--app-text/rinohtype/files/rinohtype-0.3.1-consent.patch43
-rw-r--r--app-text/rinohtype/metadata.xml7
-rw-r--r--app-text/rinohtype/rinohtype-0.3.1.ebuild44
4 files changed, 95 insertions, 0 deletions
diff --git a/app-text/rinohtype/Manifest b/app-text/rinohtype/Manifest
new file mode 100644
index 0000000..9f01540
--- /dev/null
+++ b/app-text/rinohtype/Manifest
@@ -0,0 +1 @@
+DIST rinohtype-0.3.1.tar.gz 4094637 SHA256 879a303e162d438908c2adf5f6f2146bd7bab19f8e4d9cf5635cf3cc8c07793c SHA512 3c0c0032fb7fed01b071a21ce48bca6e26310ef3e056f18bca61fcfae969a9caae4816d668dabd366fab1c144d7d236280e156d911e58bc73352769e0f372256 WHIRLPOOL 2348fac3c2a41d6300cfb97c776f85e62d63f0ae927dfc544553b0242ea69a42bbc30e08bbbfdcc247b00a436308f2a21743aef7e388728d34a022d68a68d0a0
diff --git a/app-text/rinohtype/files/rinohtype-0.3.1-consent.patch b/app-text/rinohtype/files/rinohtype-0.3.1-consent.patch
new file mode 100644
index 0000000..d217d2b
--- /dev/null
+++ b/app-text/rinohtype/files/rinohtype-0.3.1-consent.patch
@@ -0,0 +1,43 @@
+From 2735b34d8450e30eca42a149398ae3ff55f79c5f Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sun, 19 Mar 2017 01:36:11 +0100
+Subject: [PATCH] Stop installing PyPI packages on the fly without consent
+
+---
+ src/rinoh/resource.py | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/src/rinoh/resource.py b/src/rinoh/resource.py
+index 8415003..3fc541b 100644
+--- a/src/rinoh/resource.py
++++ b/src/rinoh/resource.py
+@@ -6,6 +6,7 @@
+ # Public License v3. See the LICENSE file or http://www.gnu.org/licenses/.
+
+
++import os
+ import string
+ from warnings import warn
+ from xmlrpc.client import ServerProxy
+@@ -53,9 +54,17 @@ class Resource(AttributeType):
+
+ @classmethod
+ def install_from_pypi(cls, entry_point_name):
++ resource_id = entry_point_name_to_identifier(entry_point_name)
++
++ guard_file = os.path.expanduser('~/.config/rinoh-auto-pip-enabled')
++ if not os.path.exists(guard_file):
++ print("Not installing {} resource '{}' without consent; "
++ "touch file {} to enable auto-installation if desired."
++ .format(cls.resource_type, resource_id, guard_file))
++ return False
++
+ success = False
+ pypi = ServerProxy('https://pypi.python.org/pypi')
+- resource_id = entry_point_name_to_identifier(entry_point_name)
+ distribution_name_parts = ['rinoh', cls.resource_type, resource_id]
+ for pkg in pypi.search(dict(name=distribution_name_parts)):
+ if pkg['name'] == '-'.join(distribution_name_parts):
+--
+2.12.0
+
diff --git a/app-text/rinohtype/metadata.xml b/app-text/rinohtype/metadata.xml
new file mode 100644
index 0000000..82b7b79
--- /dev/null
+++ b/app-text/rinohtype/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/rinohtype/rinohtype-0.3.1.ebuild b/app-text/rinohtype/rinohtype-0.3.1.ebuild
new file mode 100644
index 0000000..88a2a33
--- /dev/null
+++ b/app-text/rinohtype/rinohtype-0.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Python document processor"
+HOMEPAGE="https://github.com/brechtm/rinohtype"
+SRC_URI="https://github.com/brechtm/rinohtype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/purepng-0.2.0[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}
+ dev-python/rinoh-typeface-dejavuserif[${PYTHON_USEDEP}]
+ >=dev-python/rinoh-typeface-texgyrecursor-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/rinoh-typeface-texgyreheros-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/rinoh-typeface-texgyrepagella-0.1.1[${PYTHON_USEDEP}]
+ "
+
+DOCS=(
+ CHANGES.rst
+ README.rst
+ CONTRIBUTING.rst
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.1-consent.patch
+)