summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gentwoo/gentwoo-0.0.20120122-r1.ebuild')
-rw-r--r--app-portage/gentwoo/gentwoo-0.0.20120122-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-portage/gentwoo/gentwoo-0.0.20120122-r1.ebuild b/app-portage/gentwoo/gentwoo-0.0.20120122-r1.ebuild
new file mode 100644
index 0000000..cc82dff
--- /dev/null
+++ b/app-portage/gentwoo/gentwoo-0.0.20120122-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_NEEDED="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit python
+
+DESCRIPTION="Client program for Social Compiling site GenTwoo"
+HOMEPAGE="http://gentwoo.elisp.net"
+SRC_URI="http://gentwoo.elisp.net/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/simplejson"
+
+src_install() {
+ gentwoo_install() {
+ python_convert_shebangs -- ${PYTHON_ABI} gentwoo.py
+ newbin gentwoo.py gentwoo-${PYTHON_ABI}
+ }
+ python_execute_function gentwoo_install
+ python_generate_wrapper_scripts "${ED}"usr/bin/gentwoo
+
+ insinto /etc
+ doins gentwoo.conf
+}