summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/lazygal/lazygal-0.9.2.ebuild')
-rw-r--r--media-gfx/lazygal/lazygal-0.9.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-gfx/lazygal/lazygal-0.9.2.ebuild b/media-gfx/lazygal/lazygal-0.9.2.ebuild
new file mode 100644
index 0000000..95dff53
--- /dev/null
+++ b/media-gfx/lazygal/lazygal-0.9.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Static web gallery generator"
+HOMEPAGE="https://sml.zincube.net/~niol/repositories.git/lazygal/about/"
+SRC_URI="https://sml.zincube.net/~niol/repositories.git/lazygal/snapshot/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/pillow-1.1.6["${PYTHON_USEDEP}"]
+ dev-python/pyexiv2["${PYTHON_USEDEP}"]
+ >=dev-python/genshi-0.5["${PYTHON_USEDEP}"]
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt"