aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-28 17:44:10 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-28 18:35:14 -0700
commit9eac042d5e39ea30a6d26468218fa2151faf2ad8 (patch)
tree8f4b48196ccc9df10a862777273db406ede2b37f
parenttargets: Fix setting FEATURES="clean-logs" (diff)
downloadcatalyst-9eac042d5e39ea30a6d26468218fa2151faf2ad8.tar.gz
catalyst-9eac042d5e39ea30a6d26468218fa2151faf2ad8.tar.bz2
catalyst-9eac042d5e39ea30a6d26468218fa2151faf2ad8.zip
catalyst: Delete Gentoo Reference Platform target
Unused for 12 years. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--README1
-rw-r--r--catalyst/defaults.py2
-rw-r--r--catalyst/targets/grp.py97
-rw-r--r--doc/catalyst-spec.5.txt24
-rw-r--r--doc/catalyst.1.txt6
-rw-r--r--examples/grp_template.spec117
-rwxr-xr-xtargets/grp/chroot.sh21
-rwxr-xr-xtargets/grp/controller.sh34
-rwxr-xr-xtargets/grp/preclean-chroot.sh7
9 files changed, 5 insertions, 304 deletions
diff --git a/README b/README
index 6dc6a149..b398fe30 100644
--- a/README
+++ b/README
@@ -34,7 +34,6 @@ Catalyst is capable of:
- Building installation stages
- Building bootable LiveCDs
-- Building GRP (Gentoo Reference Platform) sets
- Setting up a Tinderbox target for test building
- Building netboot images
diff --git a/catalyst/defaults.py b/catalyst/defaults.py
index 705ae931..568d8566 100644
--- a/catalyst/defaults.py
+++ b/catalyst/defaults.py
@@ -17,7 +17,7 @@ required_build_targets = ["targetbase", "generic_stage_target"]
# new build types should be added here
valid_build_targets = ["stage1_target", "stage2_target", "stage3_target",
- "stage4_target", "grp_target", "livecd_stage1_target", "livecd_stage2_target",
+ "stage4_target", "livecd_stage1_target", "livecd_stage2_target",
"embedded_target", "tinderbox_target", "snapshot_target", "netboot_target",
"netboot2_target"
]
diff --git a/catalyst/targets/grp.py b/catalyst/targets/grp.py
deleted file mode 100644
index d47654d0..00000000
--- a/catalyst/targets/grp.py
+++ /dev/null
@@ -1,97 +0,0 @@
-"""
-Gentoo Reference Platform (GRP) target
-"""
-# NOTE: That^^ docstring has influence catalyst-spec(5) man page generation.
-
-import os
-import glob
-
-from catalyst import log
-from catalyst.support import (CatalystError, normpath, cmd)
-from catalyst.base.stagebase import StageBase
-
-
-class grp(StageBase):
- """
- The builder class for GRP (Gentoo Reference Platform) builds.
- """
- def __init__(self,spec,addlargs):
- self.required_values=["version_stamp","target","subarch",\
- "rel_type","profile","snapshot","source_subpath"]
-
- self.valid_values=self.required_values[:]
- self.valid_values.extend(["grp/use"])
- if "grp" not in addlargs:
- raise CatalystError("Required value \"grp\" not specified in spec.")
-
- self.required_values.extend(["grp"])
- if isinstance(addlargs['grp'], str):
- addlargs["grp"]=[addlargs["grp"]]
-
- if "grp/use" in addlargs:
- if isinstance(addlargs['grp/use'], str):
- addlargs["grp/use"]=[addlargs["grp/use"]]
-
- for x in addlargs["grp"]:
- self.required_values.append("grp/"+x+"/packages")
- self.required_values.append("grp/"+x+"/type")
-
- StageBase.__init__(self,spec,addlargs)
-
- def run_local(self):
- for pkgset in self.settings["grp"]:
- # example call: "grp.sh run pkgset cd1 xmms vim sys-apps/gleep"
- try:
- cmd([self.settings['controller_file'], 'run',
- self.settings['grp/' + pkgset + '/type'],
- pkgset] + self.settings['grp/' + pkgset + '/packages'],
- env=self.env)
-
- except CatalystError:
- self.unbind()
- raise CatalystError("GRP build aborting due to error.",
- print_traceback=True)
-
- def set_mounts(self):
- self.mounts.append("/tmp/grp")
- self.mountmap["/tmp/grp"]=self.settings["target_path"]
-
- def generate_digests(self):
- for pkgset in self.settings["grp"]:
- if self.settings["grp/"+pkgset+"/type"] == "pkgset":
- destdir=normpath(self.settings["target_path"]+"/"+pkgset+"/All")
- log.notice('Digesting files in the pkgset...')
- digests=glob.glob(destdir+'/*.DIGESTS')
- for i in digests:
- if os.path.exists(i):
- os.remove(i)
-
- files=os.listdir(destdir)
- #ignore files starting with '.' using list comprehension
- files=[filename for filename in files if filename[0] != '.']
- for i in files:
- if os.path.isfile(normpath(destdir+"/"+i)):
- self.gen_contents_file(normpath(destdir+"/"+i))
- self.gen_digest_file(normpath(destdir+"/"+i))
- else:
- destdir=normpath(self.settings["target_path"]+"/"+pkgset)
- log.notice('Digesting files in the srcset...')
-
- digests=glob.glob(destdir+'/*.DIGESTS')
- for i in digests:
- if os.path.exists(i):
- os.remove(i)
-
- files=os.listdir(destdir)
- #ignore files starting with '.' using list comprehension
- files=[filename for filename in files if filename[0] != '.']
- for i in files:
- if os.path.isfile(normpath(destdir+"/"+i)):
- #self.gen_contents_file(normpath(destdir+"/"+i))
- self.gen_digest_file(normpath(destdir+"/"+i))
-
- def set_action_sequence(self):
- self.settings["action_sequence"]=["unpack","unpack_snapshot",\
- "config_profile_link","setup_confdir","portage_overlay","bind","chroot_setup",\
- "setup_environment","run_local","unbind",\
- "generate_digests","clear_autoresume"]
diff --git a/doc/catalyst-spec.5.txt b/doc/catalyst-spec.5.txt
index 6c71b57b..7383afe8 100644
--- a/doc/catalyst-spec.5.txt
+++ b/doc/catalyst-spec.5.txt
@@ -126,11 +126,6 @@ releases, we use a default README.txt, and this will be used on your
CD if you do not provide one yourself. We do not use this for the
official releases. This setting is supported by the livecd targets.
-*grp*::
-Since GRP is capable of building packages/source sets for more than
-one CD, this defines the layout for the directories under
-`$storedir/builds` (example: `src cd2`).
-
*update_seed*::
This is an optional setting supported by stage1 to tell catalyst if
it should update the seed stage or not (valid values: `yes no`).
@@ -349,7 +344,7 @@ quite a few problems with these, so be careful with whatever `USE`
flags you add here. This is generally used for adding some
functionality that we do not want on by default for all Gentoo users,
but that we want on by default in our binaries. This setting is
-supported by the `stage4`, `netboot2`, `tinderbox`, and `grp` targets.
+supported by the `stage4`, `netboot2`, and `tinderbox` targets.
*<target>/packages*::
This is the set of packages that we will merge into the stage4 tarball
@@ -395,23 +390,6 @@ There are no checks on these packages, so be careful what you add
here. They can potentially break your target. This setting is
supported by the `stage4` and `livecd` targets.
-*grp/<label>/type*::
-This tells catalyst what type of GRP set this list of packages will
-create (example: `srcset`). Valid options here are `srcset` or
-`pkgset` to either download the source, or to build packages,
-respectively. `<label>` should match one of the labels given to
-*grp*.
-
-*grp/<label>/packages*::
-This is our list of packages that will comprise our package set
-(example: `dante tsocks sys-apps/eject minicom`). Packages listed for
-a `srcset` label should be used for grabbing things that need a
-compiled kernel to build, or things listed in the Handbook that should
-be available before the first reboot during an install. Pagekages
-listed for a `pkgset` label will be fetched, compiled, and installed
-in the target. `<label>` should match one of the labels given to
-*grp*.
-
Miscellaneous
~~~~~~~~~~~~~
diff --git a/doc/catalyst.1.txt b/doc/catalyst.1.txt
index dc6c7acb..9c52878c 100644
--- a/doc/catalyst.1.txt
+++ b/doc/catalyst.1.txt
@@ -18,9 +18,9 @@ DESCRIPTION
-----------
*catalyst* is the tool that the Gentoo Release Engineering team
utilizes to build all Gentoo Linux releases. It is capable of building
-installation stages, bootable LiveCDs, netboot images, and Gentoo Reference
-Platform (GRP) sets. *catalyst* is also capable of providing a simple
-tinderbox environment for ebuild/package testing.
+installation stages, bootable LiveCDs, and netboot images. *catalyst*
+is also capable of providing a simple tinderbox environment for package
+testing.
For more information, please visit the *catalyst* project page
on the web at 'https://wiki.gentoo.org/wiki/Catalyst'.
diff --git a/examples/grp_template.spec b/examples/grp_template.spec
deleted file mode 100644
index 3a0e15a8..00000000
--- a/examples/grp_template.spec
+++ /dev/null
@@ -1,117 +0,0 @@
-# generic GRP (Gentoo Reference Platform) specfile
-# used to build a GRP set
-
-# The subarch can be any of the supported catalyst subarches (like athlon-xp).
-# Refer to "man catalyst" or <https://wiki.gentoo.org/wiki/Catalyst>
-# for supported subarches
-# example:
-# subarch: athlon-xp
-subarch:
-
-# The version stamp is an identifier for the build. It can be anything you wish
-# it to be, but it is usually a date.
-# example:
-# version_stamp: 2006.1
-version_stamp:
-
-# The target specifies what target we want catalyst to do. For GRP, the
-# supported targets are: grp
-# example:
-# target: grp
-target: grp
-
-# The rel_type defines what kind of build we are doing. This is merely another
-# identifier, but it useful for allowing multiple concurrent builds. Usually,
-# default will suffice.
-# example:
-# rel_type: default
-rel_type:
-
-# This is the system profile to be used by catalyst to build this target. It is
-# specified as a relative path from /var/db/repos/gentoo/profiles.
-# example:
-# profile: default-linux/x86/2006.1
-profile:
-
-# This specifies which snapshot to use for building this target.
-# example:
-# snapshot: 2006.1
-snapshot:
-
-# This specifies where the seed stage comes from for this target, The path is
-# relative to $clst_sharedir/builds. The rel_type is also used as a path prefix
-# for the seed.
-# example:
-# default/stage3-x86-2006.1
-source_subpath:
-
-# These are the hosts used as distcc slaves when distcc is enabled in your
-# catalyst.conf. It follows the same syntax as distcc-config --set-hosts and
-# is entirely optional.
-# example:
-# distcc_hosts: 127.0.0.1 192.168.0.1
-distcc_hosts:
-
-# This is an optional directory containing portage configuration files. It
-# follows the same syntax as /etc/portage and should be consistent across all
-# targets to minimize problems.
-# example:
-# portage_confdir: /etc/portage
-portage_confdir:
-
-# This option specifies the location to a portage overlay that you would like to
-# have used when building this target.
-# example:
-# portage_overlay: /usr/local/portage
-portage_overlay:
-
-# This allows the optional directory containing the output packages for
-# catalyst. Mainly used as a way for different spec files to access the same
-# cache directory. Default behavior is for this location to be autogenerated
-# by catalyst based on the spec file.
-# example:
-# pkgcache_path: /tmp/packages
-pkgcache_path:
-
-# Since GRP is capable of building packages/source sets for more than one CD,
-# this defines the layout for the directories under $clst_sharedir/builds.
-# example:
-# grp: src cd2
-grp: src cd2
-
-# GRP is also able to build packages with customized USE settings. However, it
-# is very possible to cause quite a few problems with these, so be careful with
-# whatever USE flags you add here. This is generally used for adding some
-# functionality that we do not want on by default for all Gentoo users, but that
-# we want on by default in our binaries. Some examples would be things like the
-# socks5 USE flag.
-# example:
-# grp/use: gtk2 gnome kde qt bonobo cdr esd gtkhtml mozilla mysql perl ruby tcltk cups ldap ssl tcpd -svga
-grp/use:
-
-# This tells catalyst what type of GRP set this list of packages will create.
-# Valid options here are srcset or pkgset to either download the source, or to
-# build packages, respectively.
-# example:
-# grp/src/type: srcset
-grp/src/type:
-
-# Since this is a srcset, these ebuilds will have their distfiles fetched and
-# the distfiles will be stored in the src directory under $clst_sharedir/builds.
-# Packages will not be made out of this list. We use this for grabbing things
-# that need a compiled kernel to build, or things listed in the Handbook that
-# should be available before the first reboot during an install.
-# example:
-# grp/src/packages: gentoo-sources udev vanilla-sources rp-pppoe speedtouch fcdsl fritzcapi globespan-adsl pptpclient slmodem lvm2 evms iputils vixie-cron fcron dcron sysklogd metalog syslog-ng raidtools jfsutils xfsprogs reiserfsprogs dosfstools ntfsprogs lilo grub isdn4k-utils iproute2 wireless-tools wpa_supplicant pcmcia-cs hotplug coldplug dhcpcd slocate genkernel ipw2100 ipw2200 fxload logrotate
-grp/src/packages:
-
-# This is mostly here for completeness. This is the pkgset definition.
-# example:
-# grp/cd2/type: pkgset
-grp/cd2/type:
-
-# This is our list of packages that will comprise our package set. These are
-# fetched, compiled, and the packages are stored under $clst_sharedir/builds.
-# example:
-# grp/cd2/packages: dante tsocks sys-apps/eject minicom links acpid apmd parted whois tcpdump cvs zip unzip netcat partimage app-admin/sudo app-cdr/cdrtools gnome emacs dev-lang/ruby enlightenment kde mozilla-firefox mozilla-thunderbird xfce4 openbox fluxbox sylpheed openoffice-bin gimp xemacs xmms abiword gaim xchat pan tetex xcdroast k3b samba nmap gradm ettercap ethereal mplayer
-grp/cd2/packages:
diff --git a/targets/grp/chroot.sh b/targets/grp/chroot.sh
deleted file mode 100755
index 6690c91b..00000000
--- a/targets/grp/chroot.sh
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/bash
-
-source /tmp/chroot-functions.sh
-
-## START BUILD
-setup_pkgmgr
-
-export DISTDIR="/tmp/grp/${clst_grp_target}"
-export PKGDIR="/tmp/grp/${clst_grp_target}"
-
-if [ "${clst_grp_type}" = "pkgset" ]
-then
- export clst_myemergeopts="${clst_myemergeopts} --noreplace"
-else
- export clst_FETCH=1
- # This is necessary since we're setting the above variable and the emerge
- # opts have already been set
- setup_myemergeopts
-fi
-
-run_merge ${clst_grp_packages} || exit 1
diff --git a/targets/grp/controller.sh b/targets/grp/controller.sh
deleted file mode 100755
index 0f1a5b5b..00000000
--- a/targets/grp/controller.sh
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/bash
-
-source ${clst_shdir}/support/functions.sh
-
-case $1 in
- enter)
- ${clst_CHROOT} ${clst_chroot_path}
- ;;
-
- run)
- shift
- export clst_grp_type=$1
- shift
- export clst_grp_target=$1
- shift
-
- export clst_grp_packages="$*"
- exec_in_chroot ${clst_shdir}/grp/grp-chroot.sh
- ;;
-
- preclean)
- exec_in_chroot ${clst_shdir}/grp/grp-preclean-chroot.sh
- ;;
-
- clean)
- exit 0
- ;;
-
- *)
- exit 1
- ;;
-
-esac
-exit $?
diff --git a/targets/grp/preclean-chroot.sh b/targets/grp/preclean-chroot.sh
deleted file mode 100755
index 98c166fe..00000000
--- a/targets/grp/preclean-chroot.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/bash
-
-source /tmp/chroot-functions.sh
-
-cleanup_stages
-
-gconftool-2 --shutdown