aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-08 00:25:17 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-09 11:47:23 -0700
commitccddc3ae36ee4ea01db69176a993234aa56e17af (patch)
treebbec2953c2180d685bcb2dc5f1dd054c3a854c8e
parenttargets: Delete the netboot target (diff)
downloadcatalyst-ccddc3ae.tar.gz
catalyst-ccddc3ae.tar.bz2
catalyst-ccddc3ae.zip
targets: Rename netboot2 -> netboot
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--catalyst/defaults.py3
-rw-r--r--catalyst/targets/netboot.py (renamed from catalyst/targets/netboot2.py)66
-rw-r--r--examples/netboot_template.spec (renamed from examples/netboot2_template.spec)50
-rwxr-xr-xtargets/netboot/controller.sh (renamed from targets/netboot2/controller.sh)2
-rwxr-xr-xtargets/netboot/copyfile.sh (renamed from targets/netboot2/copyfile.sh)0
-rw-r--r--targets/netboot/nb-busybox.cf (renamed from targets/netboot2/nb-busybox.cf)0
-rwxr-xr-xtargets/netboot/pkg.sh (renamed from targets/netboot2/pkg.sh)0
-rwxr-xr-xtargets/support/kmerge.sh2
-rwxr-xr-xtargets/support/netboot-final.sh (renamed from targets/support/netboot2-final.sh)0
9 files changed, 61 insertions, 62 deletions
diff --git a/catalyst/defaults.py b/catalyst/defaults.py
index 11f99070..72a8f56a 100644
--- a/catalyst/defaults.py
+++ b/catalyst/defaults.py
@@ -18,8 +18,7 @@ required_build_targets = ["targetbase", "generic_stage_target"]
# new build types should be added here
valid_build_targets = ["stage1_target", "stage2_target", "stage3_target",
"stage4_target", "livecd_stage1_target", "livecd_stage2_target",
- "embedded_target", "snapshot_target",
- "netboot2_target"
+ "embedded_target", "snapshot_target", "netboot_target"
]
required_config_file_values = ["storedir", "sharedir", "distdir", "portdir"]
diff --git a/catalyst/targets/netboot2.py b/catalyst/targets/netboot.py
index 87dada3b..675a6f79 100644
--- a/catalyst/targets/netboot2.py
+++ b/catalyst/targets/netboot.py
@@ -12,7 +12,7 @@ from catalyst.fileops import (ensure_dirs, clear_dir, clear_path)
from catalyst.base.stagebase import StageBase
-class netboot2(StageBase):
+class netboot(StageBase):
"""
Builder class for a netboot build, version 2
"""
@@ -22,26 +22,26 @@ class netboot2(StageBase):
]
self.valid_values=self.required_values[:]
self.valid_values.extend([
- "netboot2/packages",
- "netboot2/use",
- "netboot2/extra_files",
- "netboot2/overlay",
- "netboot2/busybox_config",
- "netboot2/root_overlay",
- "netboot2/linuxrc"
+ "netboot/packages",
+ "netboot/use",
+ "netboot/extra_files",
+ "netboot/overlay",
+ "netboot/busybox_config",
+ "netboot/root_overlay",
+ "netboot/linuxrc"
])
try:
- if "netboot2/packages" in addlargs:
- if isinstance(addlargs['netboot2/packages'], str):
- loopy=[addlargs["netboot2/packages"]]
+ if "netboot/packages" in addlargs:
+ if isinstance(addlargs['netboot/packages'], str):
+ loopy=[addlargs["netboot/packages"]]
else:
- loopy=addlargs["netboot2/packages"]
+ loopy=addlargs["netboot/packages"]
for x in loopy:
- self.valid_values.append("netboot2/packages/"+x+"/files")
+ self.valid_values.append("netboot/packages/"+x+"/files")
except:
- raise CatalystError("configuration error in netboot2/packages.")
+ raise CatalystError("configuration error in netboot/packages.")
StageBase.__init__(self,spec,addlargs)
self.settings["merge_path"]=normpath("/tmp/image/")
@@ -67,24 +67,24 @@ class netboot2(StageBase):
and self.resume.is_enabled("copy_files_to_image"):
log.notice('Resume point detected, skipping target path setup operation...')
else:
- if "netboot2/packages" in self.settings:
- if isinstance(self.settings['netboot2/packages'], str):
- loopy=[self.settings["netboot2/packages"]]
+ if "netboot/packages" in self.settings:
+ if isinstance(self.settings['netboot/packages'], str):
+ loopy=[self.settings["netboot/packages"]]
else:
- loopy=self.settings["netboot2/packages"]
+ loopy=self.settings["netboot/packages"]
for x in loopy:
- if "netboot2/packages/"+x+"/files" in self.settings:
- if isinstance(self.settings['netboot2/packages/'+x+'/files'], list):
- myfiles.extend(self.settings["netboot2/packages/"+x+"/files"])
+ if "netboot/packages/"+x+"/files" in self.settings:
+ if isinstance(self.settings['netboot/packages/'+x+'/files'], list):
+ myfiles.extend(self.settings["netboot/packages/"+x+"/files"])
else:
- myfiles.append(self.settings["netboot2/packages/"+x+"/files"])
+ myfiles.append(self.settings["netboot/packages/"+x+"/files"])
- if "netboot2/extra_files" in self.settings:
- if isinstance(self.settings['netboot2/extra_files'], list):
- myfiles.extend(self.settings["netboot2/extra_files"])
+ if "netboot/extra_files" in self.settings:
+ if isinstance(self.settings['netboot/extra_files'], list):
+ myfiles.extend(self.settings["netboot/extra_files"])
else:
- myfiles.append(self.settings["netboot2/extra_files"])
+ myfiles.append(self.settings["netboot/extra_files"])
try:
cmd([self.settings['controller_file'], 'image'] +
@@ -101,8 +101,8 @@ class netboot2(StageBase):
and self.resume.is_enabled("setup_overlay"):
log.notice('Resume point detected, skipping setup_overlay operation...')
else:
- if "netboot2/overlay" in self.settings:
- for x in self.settings["netboot2/overlay"]:
+ if "netboot/overlay" in self.settings:
+ for x in self.settings["netboot/overlay"]:
if os.path.exists(x):
cmd(['rsync', '-a', x + '/',
self.settings['chroot_path'] + self.settings['merge_path']],
@@ -130,7 +130,7 @@ class netboot2(StageBase):
for x in self.settings[self.settings["spec_prefix"]+"/rm"]:
# we're going to shell out for all these cleaning operations,
# so we get easy glob handling
- log.notice('netboot2: removing %s', x)
+ log.notice('netboot: removing %s', x)
clear_path(self.settings['chroot_path'] +
self.settings['merge_path'] + x)
@@ -139,10 +139,10 @@ class netboot2(StageBase):
and self.resume.is_enabled("empty"):
log.notice('Resume point detected, skipping empty operation...')
else:
- if "netboot2/empty" in self.settings:
- if isinstance(self.settings['netboot2/empty'], str):
- self.settings["netboot2/empty"]=self.settings["netboot2/empty"].split()
- for x in self.settings["netboot2/empty"]:
+ if "netboot/empty" in self.settings:
+ if isinstance(self.settings['netboot/empty'], str):
+ self.settings["netboot/empty"]=self.settings["netboot/empty"].split()
+ for x in self.settings["netboot/empty"]:
myemp=self.settings["chroot_path"] + self.settings["merge_path"] + x
if not os.path.isdir(myemp):
log.warning('not a directory or does not exist, skipping "empty" operation: %s', x)
diff --git a/examples/netboot2_template.spec b/examples/netboot_template.spec
index 987cf9ed..4f76b8ff 100644
--- a/examples/netboot2_template.spec
+++ b/examples/netboot_template.spec
@@ -1,6 +1,6 @@
subarch: mips3
version_stamp: 2006.0
-target: netboot2
+target: netboot
rel_type: default
profile: uclibc/mips
snapshot: 20060107
@@ -41,16 +41,16 @@ boot/kernel/ip28r10k/gk_kernargs: --kernel-cross-compile=mips64-unknown-linux-gn
boot/kernel/ip30r10k/gk_kernargs: --kernel-cross-compile=mips64-unknown-linux-gnu- --makeopts=-j2
boot/kernel/ip32r5k/gk_kernargs: --kernel-cross-compile=mips64-unknown-linux-gnu- --makeopts=-j2
-netboot2/builddate: 20060107
-netboot2/busybox_config: /usr/share/genkernel/mips/nb-busybox.cf
+netboot/builddate: 20060107
+netboot/busybox_config: /usr/share/genkernel/mips/nb-busybox.cf
-netboot2/use:
+netboot/use:
-*
multicall
readline
ssl
-netboot2/packages:
+netboot/packages:
com_err
dropbear
dvhtool
@@ -73,14 +73,14 @@ netboot2/packages:
wget
xfsprogs
-netboot2/packages/com_err/files:
+netboot/packages/com_err/files:
/lib/libcom_err.so
/lib/libcom_err.so.2
/lib/libcom_err.so.2.1
/usr/bin/compile_et
/usr/lib/libcom_err.so
-netboot2/packages/dropbear/files:
+netboot/packages/dropbear/files:
/usr/bin/dbclient
/usr/bin/dbscp
/usr/bin/dropbearconvert
@@ -88,10 +88,10 @@ netboot2/packages/dropbear/files:
/usr/bin/dropbearmulti
/usr/sbin/dropbear
-netboot2/packages/dvhtool/files:
+netboot/packages/dvhtool/files:
/usr/sbin/dvhtool
-netboot2/packages/e2fsprogs/files:
+netboot/packages/e2fsprogs/files:
/bin/chattr
/bin/lsattr
/bin/uuidgen
@@ -132,23 +132,23 @@ netboot2/packages/e2fsprogs/files:
/usr/lib/libuuid.so
/usr/sbin/mklost+found
-netboot2/packages/jfsutils/files:
+netboot/packages/jfsutils/files:
/sbin/fsck.jfs
/sbin/jfs_fsck
/sbin/jfs_mkfs
/sbin/jfs_tune
/sbin/mkfs.jfs
-netboot2/packages/mdadm/files:
+netboot/packages/mdadm/files:
/etc/mdadm.conf
/sbin/mdadm
-netboot2/packages/nano/files:
+netboot/packages/nano/files:
/bin/nano
/bin/rnano
/usr/bin/nano
-netboot2/packages/ncurses/files:
+netboot/packages/ncurses/files:
/etc/terminfo
/lib/libcurses.so
/lib/libncurses.so
@@ -187,7 +187,7 @@ netboot2/packages/ncurses/files:
/usr/share/terminfo/x/xterm-color
/usr/share/terminfo/x/xterm-xfree86
-netboot2/packages/openssl/files:
+netboot/packages/openssl/files:
/usr/lib/libcrypto.so
/usr/lib/libcrypto.so.0
/usr/lib/libcrypto.so.0.9.7
@@ -195,38 +195,38 @@ netboot2/packages/openssl/files:
/usr/lib/libssl.so.0
/usr/lib/libssl.so.0.9.7
-netboot2/packages/popt/files:
+netboot/packages/popt/files:
/usr/lib/libpopt.so
/usr/lib/libpopt.so.0
/usr/lib/libpopt.so.0.0.0
-netboot2/packages/portmap/files:
+netboot/packages/portmap/files:
/sbin/portmap
-netboot2/packages/reiserfsprogs/files:
+netboot/packages/reiserfsprogs/files:
/sbin/fsck.reiserfs
/sbin/mkfs.reiserfs
/sbin/mkreiserfs
/sbin/reiserfsck
/sbin/reiserfstune
-netboot2/packages/rsync/files:
+netboot/packages/rsync/files:
/usr/bin/rsync
-netboot2/packages/sdparm/files:
+netboot/packages/sdparm/files:
/usr/bin/sdparm
-netboot2/packages/ss/files:
+netboot/packages/ss/files:
/lib/libss.so
/lib/libss.so.2
/lib/libss.so.2.0
/usr/bin/mk_cmds
/usr/lib/libss.so
-netboot2/packages/ttcp/files:
+netboot/packages/ttcp/files:
/usr/bin/ttcp
-netboot2/packages/uclibc/files:
+netboot/packages/uclibc/files:
/etc/ld.so.cache
/lib/ld-uClibc-0.9.27.so
/lib/ld-uClibc.so.0
@@ -269,7 +269,7 @@ netboot2/packages/uclibc/files:
/usr/lib/libthread_db.so
/usr/lib/libutil.so
-netboot2/packages/util-linux/files:
+netboot/packages/util-linux/files:
/sbin/fdisk
/sbin/mkfs
/sbin/mkswap
@@ -279,10 +279,10 @@ netboot2/packages/util-linux/files:
/usr/bin/setterm
/usr/bin/whereis
-netboot2/packages/wget/files:
+netboot/packages/wget/files:
/usr/bin/wget
-netboot2/packages/xfsprogs/files:
+netboot/packages/xfsprogs/files:
/bin/xfs_copy
/bin/xfs_growfs
/bin/xfs_info
diff --git a/targets/netboot2/controller.sh b/targets/netboot/controller.sh
index 89bb149d..d6b329e6 100755
--- a/targets/netboot2/controller.sh
+++ b/targets/netboot/controller.sh
@@ -57,7 +57,7 @@ case ${1} in
final)
# For each arch, fetch the kernel images and put them in builds/
echo -e ">>> Copying completed kernels to ${clst_target_path}/ ..."
- ${clst_shdir}/support/netboot2-final.sh
+ ${clst_shdir}/support/netboot-final.sh
;;
clean)
diff --git a/targets/netboot2/copyfile.sh b/targets/netboot/copyfile.sh
index cc1a1181..cc1a1181 100755
--- a/targets/netboot2/copyfile.sh
+++ b/targets/netboot/copyfile.sh
diff --git a/targets/netboot2/nb-busybox.cf b/targets/netboot/nb-busybox.cf
index db02678f..db02678f 100644
--- a/targets/netboot2/nb-busybox.cf
+++ b/targets/netboot/nb-busybox.cf
diff --git a/targets/netboot2/pkg.sh b/targets/netboot/pkg.sh
index 29da7134..29da7134 100755
--- a/targets/netboot2/pkg.sh
+++ b/targets/netboot/pkg.sh
diff --git a/targets/support/kmerge.sh b/targets/support/kmerge.sh
index 97d18fe7..2d642390 100755
--- a/targets/support/kmerge.sh
+++ b/targets/support/kmerge.sh
@@ -65,7 +65,7 @@ setup_gk_args() {
GK_ARGS+=(--busybox-config=/tmp/busy-config)
fi
- if [ "${clst_target}" == "netboot2" ]
+ if [ "${clst_target}" == "netboot" ]
then
GK_ARGS+=(--netboot)
diff --git a/targets/support/netboot2-final.sh b/targets/support/netboot-final.sh
index 52b85f05..52b85f05 100755
--- a/targets/support/netboot2-final.sh
+++ b/targets/support/netboot-final.sh