aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-05-18 17:59:10 -0700
committerMatt Turner <mattst88@gentoo.org>2020-10-20 18:07:32 -0700
commitf9ec6eb347542d35208a94a07af155dcd473e4e1 (patch)
treecd7a580053a7be0a4210d14018a2d39c0d6f5de7
parentcatalyst: Set jobs/load-average via catalyst.conf (diff)
downloadcatalyst-f9ec6eb3.tar.gz
catalyst-f9ec6eb3.tar.bz2
catalyst-f9ec6eb3.zip
catalyst: Configure distcc_hosts in the config file
distcc_hosts are independent of the build itself, and therefore should be configured system-wide in catalyst.conf and not in each spec file. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--catalyst/base/stagebase.py1
-rw-r--r--catalyst/defaults.py1
-rw-r--r--doc/catalyst-config.5.txt7
-rw-r--r--doc/catalyst-spec.5.txt6
-rw-r--r--etc/catalyst.conf3
-rw-r--r--examples/generic_stage_template.spec7
-rw-r--r--examples/livecd-stage1_template.spec7
-rw-r--r--examples/livecd-stage2_template.spec7
-rw-r--r--examples/stage4_template.spec7
9 files changed, 8 insertions, 38 deletions
diff --git a/catalyst/base/stagebase.py b/catalyst/base/stagebase.py
index afea5776..be7b96c8 100644
--- a/catalyst/base/stagebase.py
+++ b/catalyst/base/stagebase.py
@@ -51,7 +51,6 @@ class StageBase(TargetBase, ClearBase, GenBase):
"compression_mode",
"cxxflags",
"decompressor_search_order",
- "distcc_hosts",
"fcflags",
"fflags",
"hostuse",
diff --git a/catalyst/defaults.py b/catalyst/defaults.py
index 7a2fe3f3..0f399b56 100644
--- a/catalyst/defaults.py
+++ b/catalyst/defaults.py
@@ -11,6 +11,7 @@ from DeComp.definitions import DECOMPRESSOR_PROGRAM_OPTIONS, LIST_XATTRS_OPTIONS
valid_config_file_values = frozenset([
"compression_mode",
"digests",
+ "distcc_hosts",
"distdir",
"envscript",
"jobs",
diff --git a/doc/catalyst-config.5.txt b/doc/catalyst-config.5.txt
index cbef6092..570d42c2 100644
--- a/doc/catalyst-config.5.txt
+++ b/doc/catalyst-config.5.txt
@@ -78,7 +78,7 @@ be closed invalid.
distcc::
Enable distcc support for building. You have to set distcc_hosts in
-your spec file.
+your config file.
icecream::
Enable icecream compiler cluster support for building.
@@ -136,6 +136,11 @@ written to the target's make.conf if it is not the default value of
Other settings
~~~~~~~~~~~~~~
+*distcc_hosts*::
+These are the hosts used as distcc slaves when distcc is enabled in
+your `catalyst.conf` (example: `127.0.0.1 192.168.0.1`). It follows
+the same syntax as `distcc-config --set-hosts`.
+
*jobs*::
Integral value passed to *emerge(1)* as the parameter to --jobs and is
used to define *MAKEOPTS* during the target build.
diff --git a/doc/catalyst-spec.5.txt b/doc/catalyst-spec.5.txt
index 43cd5d2f..31e69820 100644
--- a/doc/catalyst-spec.5.txt
+++ b/doc/catalyst-spec.5.txt
@@ -74,12 +74,6 @@ This specifies where the seed stage for this target comes from
`$storedir/builds`. The `rel_type` is also used as a path prefix for
the seed.
-*distcc_hosts*::
-These are the hosts used as distcc slaves when distcc is enabled in
-your `catalyst.conf` (example: `127.0.0.1 192.168.0.1`). It follows
-the same syntax as `distcc-config --set-hosts` and is entirely
-optional.
-
*portage_confdir*::
This is an optional directory containing portage configuration files
(example: `/etc/portage`). It follows the same syntax as
diff --git a/etc/catalyst.conf b/etc/catalyst.conf
index 81693c25..b0b284fa 100644
--- a/etc/catalyst.conf
+++ b/etc/catalyst.conf
@@ -35,8 +35,7 @@ options = [
# Enable FEATURES=ccache
# "ccache",
- # Enable FEATURES=distcc. You have to set distcc_hosts in your spec
- # file.
+ # Enable FEATURES=distcc. Make sure to set distcc_hosts too.
# "distcc",
# Enable FEATURES=icecream
diff --git a/examples/generic_stage_template.spec b/examples/generic_stage_template.spec
index 01c37789..8f0375c4 100644
--- a/examples/generic_stage_template.spec
+++ b/examples/generic_stage_template.spec
@@ -82,13 +82,6 @@ compressor_arch":
#
decompressor_search_order: lbzip2 bzip2 tar pixz xz gzip squashfs
-# These are the hosts used as distcc slaves when distcc is enabled in your
-# catalyst.conf. It follows the same syntax as distcc-config --set-hosts and
-# is entirely optional.
-# example:
-# distcc_hosts: 127.0.0.1 192.168.0.1
-distcc_hosts:
-
# This is an optional directory containing portage configuration files. It
# follows the same syntax as /etc/portage and should be consistent across all
# targets to minimize problems.
diff --git a/examples/livecd-stage1_template.spec b/examples/livecd-stage1_template.spec
index c7086c91..b921372a 100644
--- a/examples/livecd-stage1_template.spec
+++ b/examples/livecd-stage1_template.spec
@@ -45,13 +45,6 @@ snapshot:
# default/stage3-x86-2006.1
source_subpath:
-# These are the hosts used as distcc slaves when distcc is enabled in your
-# catalyst.conf. It follows the same syntax as distcc-config --set-hosts and
-# is entirely optional.
-# example:
-# distcc_hosts: 127.0.0.1 192.168.0.1
-distcc_hosts:
-
# This is an optional directory containing portage configuration files. It
# follows the same syntax as /etc/portage and should be consistent across all
# targets to minimize problems.
diff --git a/examples/livecd-stage2_template.spec b/examples/livecd-stage2_template.spec
index 56bda84a..ac1cd3e4 100644
--- a/examples/livecd-stage2_template.spec
+++ b/examples/livecd-stage2_template.spec
@@ -45,13 +45,6 @@ snapshot:
# default/livecd-stage1-x86-2006.1
source_subpath:
-# These are the hosts used as distcc slaves when distcc is enabled in your
-# catalyst.conf. It follows the same syntax as distcc-config --set-hosts and
-# is entirely optional.
-# example:
-# distcc_hosts: 127.0.0.1 192.168.0.1
-distcc_hosts:
-
# This is an optional directory containing portage configuration files. It
# follows the same syntax as /etc/portage and should be consistent across all
# targets to minimize problems.
diff --git a/examples/stage4_template.spec b/examples/stage4_template.spec
index 562bfaac..c901eabc 100644
--- a/examples/stage4_template.spec
+++ b/examples/stage4_template.spec
@@ -45,13 +45,6 @@ snapshot:
# default/stage3-x86-2006.1
source_subpath:
-# These are the hosts used as distcc slaves when distcc is enabled in your
-# catalyst.conf. It follows the same syntax as distcc-config --set-hosts and
-# is entirely optional.
-# example:
-# distcc_hosts: 127.0.0.1 192.168.0.1
-distcc_hosts:
-
# This is an optional directory containing portage configuration files. It
# follows the same syntax as /etc/portage and should be consistent across all
# targets to minimize problems.