aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Trevor King <wking@drexel.edu>2012-07-09 16:23:18 +0200
committerSebastian Pipping <sebastian@pipping.org>2012-07-09 16:23:18 +0200
commit0a99c494d4602ebb92f6d352f86ec519903fdc88 (patch)
tree58930b30f0d97b7e5ff7505a67b53e922bcf62e2 /Makefile
parentReplace content on master with content from catalyst_2 (diff)
downloadcatalyst-0a99c494d4602ebb92f6d352f86ec519903fdc88.tar.gz
catalyst-0a99c494d4602ebb92f6d352f86ec519903fdc88.tar.bz2
catalyst-0a99c494d4602ebb92f6d352f86ec519903fdc88.zip
Introduce catalyst-spec(5) man page
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 30a0411f..ef4e78ed 100644
--- a/Makefile
+++ b/Makefile
@@ -2,21 +2,26 @@
# Licensed under GPL v2 or later
PACKAGE_VERSION = `fgrep '__version__=' catalyst | sed 's|^__version__="\(.*\)"$$|\1|'`
-EXTRA_DIST = files/catalyst.1
-CLEAN_FILES = $(EXTRA_DIST) doc/subarches.generated.txt
+MAN_PAGES = catalyst.1 catalyst-spec.5
+MAN_PAGE_INCLUDES = doc/subarches.generated.txt doc/targets.generated.txt
+EXTRA_DIST = $(MAN_PAGES:%=files/%)
+CLEAN_FILES = $(EXTRA_DIST) $(MAN_PAGE_INCLUDES)
distdir = catalyst-$(PACKAGE_VERSION)
all: $(EXTRA_DIST)
-files/catalyst.1: doc/catalyst.1.txt doc/subarches.generated.txt doc/asciidoc.conf Makefile catalyst
+$(MAN_PAGES:%=files/%): files/%: doc/%.txt $(MAN_PAGE_INCLUDES) doc/asciidoc.conf Makefile catalyst
a2x --conf-file=doc/asciidoc.conf --attribute="catalystversion=$(PACKAGE_VERSION)" \
--format=manpage -D files "$<"
doc/subarches.generated.txt: $(wildcard arch/*.py) doc/make_subarch_table_guidexml.py
./doc/make_subarch_table_guidexml.py
+doc/targets.generated.txt: doc/make_target_table.py $(wildcard modules/catalyst/targets/*.py)
+ "./$<" > "$@"
+
clean:
rm -f $(CLEAN_FILES)
find -name '*.pyo' -delete