aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--doc/catalyst-spec.5.txt4
-rw-r--r--examples/livecd-stage2_template.spec2
-rwxr-xr-xtargets/embedded/fs-runscript.sh6
-rwxr-xr-xtargets/support/filesystem-functions.sh4
4 files changed, 7 insertions, 9 deletions
diff --git a/doc/catalyst-spec.5.txt b/doc/catalyst-spec.5.txt
index f87bd69e..e269e16d 100644
--- a/doc/catalyst-spec.5.txt
+++ b/doc/catalyst-spec.5.txt
@@ -180,8 +180,8 @@ CD. Possible values are as follows:
*livecd/fsops*::
The fsops are a list of optional parameters that can be passed to the
tool which will create the filesystem specified in *livecd/fstype*
-(example: `-root-owned`). It is valid for the following fstypes:
-`squashfs`, `jffs`, `jffs2`, and `cramfs`.
+It is valid for the following fstypes: `squashfs`, `jffs`, `jffs2`,
+and `cramfs`.
*livecd/iso*::
This is the full path and filename to the ISO image that the
diff --git a/examples/livecd-stage2_template.spec b/examples/livecd-stage2_template.spec
index 4cb94d40..3b9ca1da 100644
--- a/examples/livecd-stage2_template.spec
+++ b/examples/livecd-stage2_template.spec
@@ -95,8 +95,6 @@ livecd/fstype:
# The fsops are a list of optional parameters that can be passed to the tool
# which will create the filesystem specified in livecd/fstype. It is valid for
# the following fstypes: squashfs, jffs, jffs2, cramfs
-# example:
-# livecd/fsops: -root-owned
livecd/fsops:
# The cdtar is essentially the bootloader for the CD. It also holds the main
diff --git a/targets/embedded/fs-runscript.sh b/targets/embedded/fs-runscript.sh
index 8d5abab1..4746a909 100755
--- a/targets/embedded/fs-runscript.sh
+++ b/targets/embedded/fs-runscript.sh
@@ -32,9 +32,9 @@ case ${1} in
;;
squashfs)
- fs_check /usr/bin/mksquashfs squashfs sys-fs/squashfs-tools
- mksquashfs ${root_fs_path} ${clst_image_path}/root.img \
- ${clst_embedded_fs_ops} || \
+ fs_check /usr/bin/gensquashfs squashfs sys-fs/squashfs-tools-ng
+ gensquashfs -D ${root_fs_path} -q ${clst_embedded_fs_ops} \
+ ${clst_image_path}/root.img ||
die "Could not create a squashfs filesystem"
;;
diff --git a/targets/support/filesystem-functions.sh b/targets/support/filesystem-functions.sh
index 0c144ba8..a4d31b4e 100755
--- a/targets/support/filesystem-functions.sh
+++ b/targets/support/filesystem-functions.sh
@@ -55,8 +55,8 @@ create_noloop() {
create_squashfs() {
echo "Creating squashfs..."
export loopname="image.squashfs"
- mksquashfs "${clst_destpath}" "$1/${loopname}" ${clst_fsops} -noappend \
- || die "mksquashfs failed, did you emerge squashfs-tools?"
+ gensquashfs -D "${clst_destpath}" -q ${clst_fsops} "$1/${loopname}" \
+ || die "gensquashfs failed, did you emerge squashfs-tools-ng?"
}
create_jffs() {