aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'INSTALL')
-rw-r--r--INSTALL40
1 files changed, 24 insertions, 16 deletions
diff --git a/INSTALL b/INSTALL
index 97454ce..8ecad8e 100644
--- a/INSTALL
+++ b/INSTALL
@@ -7,35 +7,42 @@ Dependencies:
- Working PostgreSQL database
* Tinderbox - running as root
+Easiest way to install collagen is by using python setup.py script:
+ # python setup.py install
+This will install collagen python files, data and wrapper scrips.
- ==================== INSTALLING Matchbox ====================
+Alternatively you can use ebuild file included with distribution.
+
+
+ ==================== Configuring Matchbox ====================
First we need to setup database connection. This is done by setting
-variables in src/matchbox/db/settings.py. Now initialization of db
-schema is in order. We use django tools to create it for us from model
-description. For initialization do this(in collagen root directory):
+variables in configuration module for django (example file can be
+found at /usr/share/doc/collagen-1.0/db_config.py). Now initialization
+of db schema is in order. We use django tools to create it for us from
+model description. For initialization do this:
-cd src/
-django-admin.py syncdb --settings=matchbox.db.settings --pythonpath=.
-django-admin.py loaddata matchbox/db/main/initial_data.json \
- --settings=matchbox.db.settings --pythonpath=.
+ $ django-admin.py syncdb --settings=db_config --pythonpath=.
+ $ django-admin.py loaddata /usr/share/collagen-1.0/initial_data.json \
+ --settings=db_config --pythonpath=.
If the database schema exists and you need to fix it, drop the tables
-beforehand, because django-admin.py will skips tables that exist
+beforehand, because django-admin.py will skip tables that exist
already.
-All we need to do now is start the server:
+All we need to do now is start the server (can be run as regular user)
-python matchbox.py
+ $ matchbox.py
- ==================== INSTALLING Tinderbox ====================
+ ==================== Configuring Tinderbox ====================
This is a little bit easier than Matchbox. We need to set path of
-mktinderboxchroot.sh script in src/tinderbox/config.py. This is done
-by setting variable MK_CHROOT_SCRIPT.
+mktinderboxchroot.sh script and few other settings in tinderbox
+configuration file (example can be found at
+/usr/share/doc/collagen-1.0/tinderbox_config.py).
Other variables that need to be setup are:
MATCHBOX_HOST - ip or hostname of matchbox host
@@ -53,6 +60,7 @@ CHROOT_LOGS - this is directory inside WORK_CHROOT where logging and
LOG_LEVEL - you can leave this to log.DEBUG until collagen is
rock-solid :-)
-Now we need to run tinderbox:
+Now we need to run tinderbox with tinderbox_config.py in current dir
+(as root):
-sudo python tinderbox.py \ No newline at end of file
+ # tinderbox.py \ No newline at end of file