aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-02-11 12:26:52 +0100
committerUlrich Müller <ulm@gentoo.org>2020-02-11 12:26:52 +0100
commit37415c314cd0bbbc07f7f43b3364abed2cb641d3 (patch)
tree2f1b6c2065a37b77578b59140cca0e7c72f730da
parentappendices/contributing: Don't mention download of single xml files. (diff)
downloaddevmanual-37415c31.tar.gz
devmanual-37415c31.tar.bz2
devmanual-37415c31.zip
Makefile: Remove quirks necessary for installing in-place.
Now that infra installs into a separate target directory, we no longer need atomicity during the build. Remove the delete-old rule as well, which was intended for the same purpose. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index d8e3547..b93a85e 100644
--- a/Makefile
+++ b/Makefile
@@ -41,8 +41,7 @@ build: $(HTMLS) $(IMAGES)
# document in devmanual gets a unique ID, which is used to
# quickly tie search matches to the corresponding documents.
documents.js: bin/build_search_documents.py $(XMLS)
- ./bin/build_search_documents.py $(XMLS) > _documents.js
- mv _documents.js documents.js
+ ./bin/build_search_documents.py $(XMLS) > $@
%.png : %.svg
rsvg-convert --output=$@ $<
@@ -89,14 +88,7 @@ tidy: $(HTMLS) $(ECLASS_HTMLS)
test $${status} -eq 0 && echo "tidy validation successful"; \
exit $${status}
-# Delete any orphaned html and image files that could be left over
-# after the corresponding source file was moved or removed.
-delete-old:
- @-rm -f $(filter-out $(HTMLS) $(ECLASS_HTMLS) $(IMAGES), \
- $(filter %/index.html %.png,$(ALL_FILES)))
- @find . ! -path './.git*' -type d -empty -delete
-
clean:
- @rm -f $(HTMLS) $(IMAGES) _documents.js documents.js
+ @rm -f $(HTMLS) $(IMAGES) documents.js
-.PHONY: all prereq build install validate tidy delete-old clean
+.PHONY: all prereq build install validate tidy clean