aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-04-02 10:38:08 +0200
committerUlrich Müller <ulm@gentoo.org>2016-04-02 10:38:08 +0200
commit3d3e03c8f83de3b9fde8589c995d0f70c641556b (patch)
tree91322d68b64315838065f9325155091623336546
parentMakefile: construct the full dependency tree instead of pattern matching (diff)
downloaddevmanual-3d3e03c8.tar.gz
devmanual-3d3e03c8.tar.bz2
devmanual-3d3e03c8.zip
Update years in example ebuild and eclass headers.
Also escape any VCS keywords that could potentially be expanded.
-rw-r--r--ebuild-writing/common-mistakes/text.xml2
-rw-r--r--ebuild-writing/eapi/text.xml12
-rw-r--r--ebuild-writing/file-format/text.xml9
-rw-r--r--ebuild-writing/functions/src_prepare/epatch/text.xml4
-rw-r--r--ebuild-writing/functions/src_unpack/rpm-sources/text.xml4
-rw-r--r--ebuild-writing/misc-files/patches/text.xml4
-rw-r--r--ebuild-writing/using-eclasses/text.xml4
-rw-r--r--eclass-writing/text.xml12
-rw-r--r--quickstart/text.xml20
9 files changed, 36 insertions, 35 deletions
diff --git a/ebuild-writing/common-mistakes/text.xml b/ebuild-writing/common-mistakes/text.xml
index 1716e5d..8293bc8 100644
--- a/ebuild-writing/common-mistakes/text.xml
+++ b/ebuild-writing/common-mistakes/text.xml
@@ -158,7 +158,7 @@ The first three lines <e>must</e> look like this:
</p>
<pre caption="Valid Header">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# &#36;Id&#36;
</pre>
diff --git a/ebuild-writing/eapi/text.xml b/ebuild-writing/eapi/text.xml
index 239f6f3..8045b28 100644
--- a/ebuild-writing/eapi/text.xml
+++ b/ebuild-writing/eapi/text.xml
@@ -42,9 +42,9 @@ Most developers prefer to set the EAPI version without quotes. However, the PMS
</note>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
EAPI=5
inherit eutils
@@ -120,9 +120,9 @@ src_compile() {
</important>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
EAPI=1
@@ -515,9 +515,9 @@ DEPEND="
</p>
<p>Example:</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
EAPI=4
inherit linux-info
diff --git a/ebuild-writing/file-format/text.xml b/ebuild-writing/file-format/text.xml
index 74a623e..e74fd15 100644
--- a/ebuild-writing/file-format/text.xml
+++ b/ebuild-writing/file-format/text.xml
@@ -138,14 +138,15 @@ is to use <c>9999</c> as the version (or as the last version component).
<p>
All ebuilds committed to the tree should have a three line header immediately at
the start indicating copyright. This must be an exact copy of the contents of
-<c>$(portageq get_repo_path / gentoo)/header.txt</c>. Ensure that the <c>$Id$</c> line is not
-modified manually <d/> will be expanded on staging box. See <uri link="::general-concepts/git-to-rsync"/>.
+<c>$(portageq get_repo_path / gentoo)/header.txt</c>. Ensure that the
+<c>&#36;Id&#36;</c> line is not modified manually <d/> will be expanded
+on staging box. See <uri link="::general-concepts/git-to-rsync"/>.
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
</codesample>
</body>
diff --git a/ebuild-writing/functions/src_prepare/epatch/text.xml b/ebuild-writing/functions/src_prepare/epatch/text.xml
index 2401bdc..a8d5f04 100644
--- a/ebuild-writing/functions/src_prepare/epatch/text.xml
+++ b/ebuild-writing/functions/src_prepare/epatch/text.xml
@@ -69,8 +69,8 @@ Remember to add the patch to <c>SRC_URI</c>.
<title>Git Keyword Expansion Lines and Patches</title>
<body>
<p>
-If your patch includes any changes to Git <c>$Id$</c>
-(or <c>$Date$</c>) lines, it cannot be
+If your patch includes any changes to Git <c>&#36;Id&#36;</c>
+(or <c>&#36;Date&#36;</c>) lines, it cannot be
distributed under <c>files/</c>, since Git will clobber the patch when
keywords are expanded on the staging box. In these situations, either remove this hunk of the patch
manually, or mirror the file. See <uri link="::general-concepts/git-to-rsync"/>.
diff --git a/ebuild-writing/functions/src_unpack/rpm-sources/text.xml b/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
index 0ff0def..0046e20 100644
--- a/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
+++ b/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
@@ -52,9 +52,9 @@ patches. The filename should be <c>suse-fetchmail-6.2.5.54.1.ebuild</c>.
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
inherit eutils versionator rpm
diff --git a/ebuild-writing/misc-files/patches/text.xml b/ebuild-writing/misc-files/patches/text.xml
index cd85244..4bb8375 100644
--- a/ebuild-writing/misc-files/patches/text.xml
+++ b/ebuild-writing/misc-files/patches/text.xml
@@ -107,8 +107,8 @@ from the <c>vim</c> patch tarball:
<p>
When adding a patch to the tree be sure to check that the patch doesn't have
-Git keywords in it that will be expanded (such as <c>$Id$</c>). If the patch
-contains these, it will break manifests unless you add it to the tree
+Git keywords in it that will be expanded (such as <c>&#36;Id&#36;</c>). If
+the patch contains these, it will break manifests unless you add it to the tree
correctly. In the case that it does have the keywords, you should remove them.
Afterwards they can be added like every other file:
</p>
diff --git a/ebuild-writing/using-eclasses/text.xml b/ebuild-writing/using-eclasses/text.xml
index d10f4fc..495d03c 100644
--- a/ebuild-writing/using-eclasses/text.xml
+++ b/ebuild-writing/using-eclasses/text.xml
@@ -30,9 +30,9 @@ After inheriting an eclass, its provided functions can be used as normal. Here's
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
EAPI=2
diff --git a/eclass-writing/text.xml b/eclass-writing/text.xml
index 63aaf9c..1a115b1 100644
--- a/eclass-writing/text.xml
+++ b/eclass-writing/text.xml
@@ -176,9 +176,9 @@ a single function, <c>domacosapp</c>.
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
#
# Original Author: Ciaran McCreesh &lt;ciaranm@gentoo.org&gt;
@@ -263,9 +263,9 @@ something like the following:
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
# Original Author: Ciaran McCreesh &lt;ciaranm@gentoo.org&gt;
# Purpose: Demonstration of EXPORT_FUNCTIONS. Defines simple wrappers for the
@@ -306,9 +306,9 @@ for an eclass to invoke die from the global scope. For example:
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
# Purpose: Demonstration of die upon invalid EAPI usage.
diff --git a/quickstart/text.xml b/quickstart/text.xml
index 561e4cd..e919716 100644
--- a/quickstart/text.xml
+++ b/quickstart/text.xml
@@ -34,9 +34,9 @@ can see real ebuilds in the main tree).
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
EAPI=5
@@ -206,9 +206,9 @@ Here's <c>app-misc/detox/detox-1.1.1.ebuild</c>:
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
EAPI=5
@@ -271,9 +271,9 @@ this is done via <c>inherit eutils</c> at the top of the ebuild. Here's
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
EAPI=5
@@ -329,9 +329,9 @@ replacement iconv for <c>libc</c> implementations which don't have their own.
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
EAPI=5
@@ -373,9 +373,9 @@ Another more complicated example, this time based upon
</p>
<codesample lang="ebuild">
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# &#36;Id&#36;
EAPI=5