aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-02-07 06:33:15 +0100
committerUlrich Müller <ulm@gentoo.org>2020-02-07 06:33:15 +0100
commit6f5b13920552d6882bcb5103e84d3a3146bd632c (patch)
tree45ea2624bfd37679bdb3f98eaabfa233779b4e14
parentMakefile: New target "delete-old". (diff)
downloaddevmanual-6f5b1392.tar.gz
devmanual-6f5b1392.tar.bz2
devmanual-6f5b1392.zip
Makefile: Drop "delete-old" from all prerequisites.
By popular demand. Also drop "prereq" as prerequisite of "validate", because it is already listed with "all". Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index d379bd3..d1515fb 100644
--- a/Makefile
+++ b/Makefile
@@ -10,7 +10,7 @@ IMAGES := $(patsubst %.svg,%.png,$(SVGS))
# Nonzero value disables external assets for offline browsing.
OFFLINE = 0
-all: prereq validate delete-old build documents.js
+all: prereq validate build documents.js
prereq:
@type rsvg-convert >/dev/null 2>&1 || \
@@ -54,7 +54,7 @@ documents.js: bin/build_search_documents.py $(XMLS)
%.html: $$(dir $$@)text.xml devbook.xsl xsl/*.xsl $$(subst text.xml,index.html,$$(wildcard $$(dir $$@)*/text.xml))
xsltproc --param offline "$(OFFLINE)" devbook.xsl $< > $@
-validate: prereq
+validate:
@xmllint --noout --dtdvalid devbook.dtd $(XMLS) \
&& echo "xmllint validation successful"
@@ -77,7 +77,7 @@ delete-old:
$(filter %/index.html %.png,$(ALL_FILES)))
@find . ! -path './.git*' -type d -empty -delete
-clean: delete-old
+clean:
@rm -f $(HTMLS) $(IMAGES) _documents.js documents.js
.PHONY: all prereq validate build tidy delete-old clean