aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-01-02 14:35:35 +0100
committerUlrich Müller <ulm@gentoo.org>2020-01-02 14:35:35 +0100
commit832b6ab7ea3e5239ec1ad850ca08a85dc1cb3bb1 (patch)
tree20babc73f1912dc1496f63faa4ecaef5fba647d2
parentUpdate copyright years. (diff)
downloaddevmanual-832b6ab7.tar.gz
devmanual-832b6ab7.tar.bz2
devmanual-832b6ab7.zip
Makefile: Output a message if tidy succeeded.
Explicitly initialise status, in order to be independent of the environment. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 407decf..398d976 100644
--- a/Makefile
+++ b/Makefile
@@ -53,10 +53,12 @@ validate: prereq
# We have to loop through them because otherwise tidy won't
# tell you which file contains a mistake.
tidy: $(HTMLS)
- @for f in $(HTMLS); do \
+ @status=0; \
+ for f in $(HTMLS); do \
output=$$(tidy -q -errors --drop-empty-elements no $${f} 2>&1) \
|| { status=$$?; echo "Failed on $${f}:"; echo "$${output}"; }; \
done; \
+ test $${status} -eq 0 && echo "tidy validation successful"; \
exit $${status}
clean: